VF61 CE 6.0 File Permission Denied

I’m trying to upload a file to FTP server using OpenNETCF.Net.Ftp ,
C# , CE 6.0 , .NET 3.5 .

The connection to FTP server works fine , but when I try to upload the file I get Permission Denied,
I tried to to put the file on //USB HD// , also tried to put it on //FlashDisk//, still same problem .

Any suggestions of how I should give that file a permission to be uploaded?

Hello @MarkDavydov,

Are you sure for the specified path because in C# .Net on WinCe it should be \Flashdisk\ or @"\Flashdisk" with backslash ("") not slash ("/"). Perhaps this is your problem.

Other possibility perhaps this exception mean the account you use is not allowed to write files on the server. Have you tested the FTP server with a tool like FileZilla before try to do it on the VF61?

Aurélien.

You were right , I had a problem with my FTP server, it had some file protection that stopped me from uploading any files to it , even though I have set all the permissions for that user, that’s why I though there is some Win CE file protection.

My bad and thank you for the help!