VF61 Active Sync Driver installation


Today, AS driver instalation is started each time when a new Colibri VF61 is connected to PC. On PXA320, driver is installed once time and new modules are not required driver installation. How do that VF61 drivers installation has same behaviour like a PXA320?


Hi, so far I did not notice anything like this. Can you check your target PC. Does this happening on more PCs? What is the OS version on your PC?

I tested on several PC with Windows 7.

Could you try Win 10? Does the same happen? Is config block inside your device valid? Could you erase the registry on device?

This happening also on Win 10.
This happening with new Colibri from manufacturer, before device flashing/erasing, registry update and other customization.

What about this issue? Any ideas?

I did not notice this on my 2 PCs. Do you maybe see are vid and pid always the same when you connect?

Yes I do. I am see vid and pid always the same

I create video: https://drive.google.com/open?id=0B-Y0zQ3ah1HrZjZ4eWhwbk1EQkU

I tried using the same EVB as you are using and I still can’t get it to reload the driver. Do you also force Colibri to lower USB speed? You need to add registry

HKLM\Drivers\Builtin\USBOTG\UFN you need to add DWORD value “highspeed” and set it to 1.

I tested with “HKLM\Drivers\Builtin\USBOTG\UFN you need to add DWORD value “highspeed” and set it to 1” registry setting and got same issue.

We managed to reproduce this on some Win 7 PCs. I will create a ticket about this and inform you about the planned timeline for a fix.

Could you please test this image → https://share.toradex.com/1uf0o0dcaqi5elv

You need to update bootloader and image. If it will work let me know and we will merge it to next release.

I test this image and issue isn’t fixed. It is tested on Win7 and XP.

What about this issue?

I am looking into this but I am not able to reproduce it with 1 module. I see you are using old EVB. Do you force speed of USB in registry? Or did you patch the EVB?

EVB isn’t patched. I tested with “highspeed” = 1 and issue exists.

Did you check with highspeed = 0 ?

Yes, I did

Can the computer settings be the cause of this behavior? For example: register settings, PnP settings, policy and etc?