VF61 1.2A Win CE7 Ethernet Connection failure after some period

If put module to ping server it will crash after 1-2h. It will report transmit failed, error code 11010 and Error 11003. After flush ram ( cold boot ) ethernet connection is running properly again, until it crash again. BSP version is 1.3? Any thoughts about that?

Can this problem be joined with this already fixed bug issue:

15502 Serial port crashes after about 40min Known Issue Colibri VF50, Colibri VF61 UART CE6, WEC2013, WEC7 Fixed


What is the exact version you are using? 1.3beta3? or 1.3beta4?

V1.3beta 1

It seems to be that there is no same ethernet crash in version 1.3 beta 4. So maybe there is someting fatal fixed between version 1 and 4 what effect to ethernet function. Because that 1.3 beta version 1 crashed usually after 45min ethernet usage or something so it can be some kind of memory overflow.

I have the same problem on V1.3beta1 version, WinCE 6.0.
My application uses Ethernet and Serial ports.

After install V1.3beta3 problem disapears.

First thing would be to update to BETA4. You can find downloads on developers network. http://developer.toradex.com/

Is there something wrong in CE6 V1.3beta4 in Ethernet? If I start ping server continuously in cmd it will goes jam after 1-2h usage and through error code 11010 and when closing cmd and start again ping it will give Bad IP address (null) message. If I do cold boot it will fix issue for a moment. I got this same error in EC7 older version 1.3 beta 1 and in 1.3 beta 4 it is fixxed. The bug is still in the CE6 version? CE6 and EC7 using same bootloader version right?

Driver on 6 and 7 is different. I am now running a test for 5h and it works. I will leave it running over night.

I just finished 24hours test and its still running. I will leave it for next 3 days. Do you have anything else than ENET running?

That’s weird. I just tested 1,5h and get that jam again. I had also terminal software open and serial port connection open but that remained functional. Only ping goes down in cmd. And if I type “ipconfig /all” there is only text “Windows IP configuration” and nothing more. And if I not type “ping google.com” it will print “Bad IP address(null).”

If I run cold boot, ethernet connection goes up again and ipconfig settings will also print properly in cmd.

Module 1.2A
VF61 IT 256
Ver: 1.3 BETA, Build 4 (CE 6.0)
Built: 07 Apr 2016

This error seems to be exactly the same than in the old EC7 version.

What carrier board do you use?

It is a custom and produced by our company. Pretty much same than Iris 1.1. If I change windows version to EC7 newest version problem disappears so I don’t think so that is hw related issue. I could also test that module with Iris and I think I will do that for next.