VF50 USB Host Function autoswitch

On a VF50 based custom board the USB is setup in this way:
USB1 (SODIMM pins 139/141) is always host (for keyboard and flash drives)
USB2 (SODIMM pins 143/145) is function/slave (A’sync) or like USB1, using a jumper field on the USB wires.
When USB2 is jump’ed as slave - A’Sync works, and when jump’ed as host - keyboard works, BUT not flash drive. And that’s the problem. USB1 (running host only) has the same problem - keyboard works but not flash drives. I have tried different flash drive types without luck. The hardware is according to Colibri eval board 3.2.
Moving the VF50 brick to the Colibri Eval board 3.2 - the USB flash drives connected to X31 or X32, pops up in the explorer just fine.
The registry is like this:
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\HCD_HSH1] “Dll”=“hcd_hsh1.dll”
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\HCD_HSH2] “Dll”="_hcd_hsh1.dll"
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\UFN] “Dll”="_usbfn.dll"
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USBOTG] “Dll”=“otg_vybrid.dll”
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USBOTG\Hcd] “Dll”=“hcd_hsh1.dll”
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USBOTG\UsbFn] “Dll”=“usbfn.dll”
“HighSpeed” key in not entered in registry.
Any good ideas on this issue?. Thanks.

It looks like the custom board is not quite like Colibri eval board 3.2 when it comes to USB. I have removed all 100pF capasitors and terminating resistors - leaving just the clamping diodes and line filter. And now it works. Both function and host - and host for both USB, and the jumpering.
So - no Toradex problem - case closed. Thanks.

Dear @Embedx,

Thank you for posting your findings on our community.

It seems to be a USB host that is configured to Full speed. After you removing the capacitors and terminating resistors now USB high speed, therefore, Flashdrive works now.

Please feel free to contact us in case if you need any support from our side.