VF50 update issue with WEC2013 (Bricked module)

HI Toradex,

I have received some VF50 modules v.1.2A.
They are loaded with WindowsCE 6.0. I need to load them with WEC2013

I used the latest vybrid image release (1.4 Beta1) and the update tool supplied with that release.
I select the nk8.bin in the update tool. Everything went OK.
After reboot i see the bootloader writting stuff to terminal and display as always.
But then nothing more happens. No shell, no ping, no nothing??
I tried clearing registry from bootloader menu but no luck.

I than tried the recovery mode. Closed the terminal program. Launched the recovery command line:

imx_uart.exe COM3: .\vybrid_eboot.conf

Shorten recovry pads on the module and powered on.
Nothing did happen in the command windows:

D:\recovery>imx_uart.exe --no-rtscts COM3: .\vybrid_eboot.conf
config file <.\vybrid_eboot.conf>
parse .\vybrid_eboot.conf
starting associating phase

Now the module is completly bricked. No bootloader output anymore…

Any advise?


Did you also update bootloader to 1.4b1?


I could only select the BIN files.
Is the eboot,img in the ZIP the new bootloader?

But how does that effect that the module is bricked after I have activated the recovery pads?

Hi again,

I just tried another module. It has bootloader v1.3 and WinCE6.
I now updated the bootloader to v1.4 beta 1 and rebooted…

Now it cannt load the windows CE image.
It is stuck in the bootloader screen with OEMLaunch 80004000

Are there error in the 1.4 beta release?

How to proceed?


Our bootloaders change with new version and same was for loader version 1.4.

It changed a bit how image is saved in NAND so when you flash new bootloader and use old image it may not boot.

When you migrate to new versions you should always take care that bootloader and image are same version. ( I would also recommend clearing registry when you go from older versions to newer ones )

So if I update I should first clear the registry
Than I update the bootloader.
Than ignore the request to reboot
Than update the image
Than reboot

Now that is it stuck in the bootloader v1.4 how do I update with the matching image?
When I activate the F option in the bootloader it tries to get the image over ethernet.

Would it work using the Eshell app and load the image matching the bootloader?

If you can access the eboot command line you can use the flashimage command.
Just write your nk8.bin file on a FAT-formatted SD card and type:
flashimage nk8.bin
in the eboot console (you can access that by pressing space and then X on the serial terminal immediately after power-up).