Verdin IMX8MM board, getting Could not initialize PHY ethernet@30be0000 BOOTP broadcast 1 BOOTP broadcast 2

Hi everyone,
Tried to splash the screen on Linux kernel
everything was successful as per below document

Started flashing through toradex easy installer but while booting Im getting error like below (see the .png file)
Scanning usb 0:1…
ethernet@30be0000 Waiting for PHY auto negotiation to complete… TIMEOUT !
Could not initialize PHY ethernet@30be0000
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9

Hi @Akhil.y,
There were 2 methods that you tried to deploy your splash screen

  1. When you replaced the kernel with custom splash screen inside the boot folder. This worked for you
  2. Deploying kernel using Toradex Easy Installer
    I tested both the methods and both work fine.

Let me know the steps you did to deploy the kernel using Toradex Easy Installer.
Also, try setting to default environment
env default -a

Hi sahil,
The steps I used to deploy the kernel using easy installer was
->In Multimedia image unpacked the bootfs file and deleted the packed one.
->Replaced the image.gz file in bootfs file and tar it and converted to .tar.xz format.
->Copied that image in pendrive
->Started flashing through easy installer

getting above issue
tried with default environment as well but no luck

Hi @sahil.tx
I tried with default environment and saved the env and booted, getting same issue

Hi @Akhil.y ,
Can you share the custom kernel , I will test here.
Also let me know the exact image version you are testing with.

Hi @sahil.tx
The Image version we are trying to test with is given below


You are asking to send the Image.gz file ?

Hi @Akhil.y ,
Yes I am talking about image.gz

Hi @sahil.tx
Is there any link to send ? or should I mail it to you ?
here maximum size was 4MB.
our custom kernel was more than 4MB

Hi @sahil.tx
We are requesting a call with you, regarding this issue, could you please confirm your availability tomorrow, so that we can have session regarding this.
Akhil Y

Hi @Akhil.y ,
We recommend to use for file sharing

Hi @sahil.tx
please follow the below link to get our custom kernel

And also sahil,
we need a small discussion with you regarding BOOTP issue
can you please let us know at what time you are available today ? so that I can schedule a call.

Thanks and Regards
Akhil Y

Hi @sahil.tx
If today not possible, will postpone it to tomorrow.
could you please tell us the time to schedule the remote session.

Akhil Y

Hi @Akhil.y,

In our discussion, we observed that the issue was with the packing and unpacking of the bootfs folder.
My recommendation is to use a linux host when when doing development on linux.

Hi @sahil.tx
Working fine.
Thank you