Verdin IMX8M Plus Qt Creator

I have devkit “Verdin IMX8M Plus and Verdin Dev board”.
I am new to Qt Device Creation so any additional information will be helpful for me. Thank you in advance!!!

Initially, I tried to connect to Qt Creator. QBSP support for IMX8M Plus only starts with version “Boot2Qt 6.4.3 NXP i.MX 8M Plus LPDDR4 EVK”. And all available images from Toradex use meta-qt5 - but even with them I couldn’t connect to Qt Creator. Then I built the image myself according to the instructions from the official site:

Everything built together ok and I was able to connect to Qt Creator. But I can’t launch the test project, since the image has Qt version 5.15 and the compiler version is 6.4.3. The error on dev kit appears - there are no libraries for Qt Gui 6 version.

Then I tried to build the same official image but with meta-qt6 as described here:

But I get an error for 6.4.3. so for the latest 6.5.1 in qtapplicationmanager:
ERROR: qtapplicationmanager-6.5.1-r0 do_configure: ExecutionError(‘/home/stan88/oe-core/build/tmp/work/cortexa53-tdx-linux/qtapplicationmanager/6.5.1-r0/temp/run.do_configure.278724’, 1, None, None)

As I understand correctly, there is ability to compile an image for this platform for meta-qt6. Could you help me what layers and versions will be better to use? Maybe you have some description? And is it possible to connect and debug through Qt Creator in a different way without using QBSP? Perhaps I missed something.

Regards, Stanislav.

Hi @Stan88 !

Welcome to the Toradex Community! :tada:

We have the following article on Developer about Qt for Device Creation: Qt for Device Creation (Boot to Qt) | Toradex Developer Center

From there we can see that there is no support for Verdin iMX8M Plus. But, anyway, we will check internally.

We also have the following article that might help you with your Qt Creator setup:

More specific Qt questions might be better answered on Qt Forum ( or their documentation (

Let us know if this helps you :wink:

Best regards,

Thanks for the links.

I figured out compiler versions and compiling images. The most stable version is 5.15 and dunfell. Now I can connect via Qt creator, upload and run my application on a current devkit. But I still can’t debug. I can’t find /usr/bin/appcontroller even though I included the meta-qt5 and meta-b2qt layers when compiling. Could you help me, what other changes need to be made in the yocto configurations so that it appears in the final version and debugging works?

Regards, Stanislav.

Hi @Stan88 !

The article shared above (How to set up Qt Creator to cross compile for embedded Linux | Toradex Developer Center) also shows how to setup Qt Creator in order to debug on target.

Did you follow that part?

What exact problem are you facing? The more information you share, better it is to help you :slight_smile:

Best regards,

Hello @Stan88,

Do you have any updates on this topic?

Hi Rudhi.

Currently I am using version Qt 5.15. I downloaded the “appcontroller” from github and compiled it under version 5.15 and uploaded it to the directory - /usr/bin/
After that I have deploy and debug for version Qt 5.15.

I also managed to build Toradex multimedia image with Qt 6. But I can’t display the graphical part of the app - display error via Westen + Wayland. I already contacted Qt support and within the next week they promised to give an answer on this issue.

Hi @Stan88 !

Do you have any updates regarding this topic? Were you able to advance?

Best regards,