Using rtcwake with Verdin and Torizon 5.1


I’m interested in putting our Verdin IMX8MM system into a sleep/suspend mode in periods when it is not used. I was hoping to just use rtcwake but it does not seem configured in Torizon 5.1 for RTC wakeup events.

verdin-imx8mm-06760593:~$ sudo rtcwake -m mem -s 10
rtcwake: assuming RTC uses UTC ...
rtcwake: cannot open /sys/class/rtc/rtc0/device/power/wakeup: No such file or directory
rtcwake: /dev/rtc0 not enabled for wakeup events

All suggestions very welcome.



I figured this out, looks like rtc1 is the device to use so you need to specify it in the rtcwake command:

 sudo rtcwake -m mem -d rtc1 -s10

Perfect that it works. Thanks for the feedback.