Using Media Player with CE6, T20

Hi

I’m trying to use the Media Player that is included with the WindowsCE6 Colibri T20 image (2.3), but I have a couple of questions.

It works when I start the exe by doubleklicking or from the command prompt without specified file and then select the video. It also works when doubleklicking the video file. But it does not work when trying to run from the command prompt. I tried all variations of how to enter the filename, with full path, or without path while beeing in the right directory, but I can’t get it to start the specified video, the player just closes itself.

Also in the doc (Media Player (Colibri)) there is only the fullscreen option mentioned ( /f ) - are there other command options available as well, or can this be done via registry (e.g. play video once and then close)?

Thanks!

Dear @UncreativeNickname08

The player works fine from command line. You need to provide the full path to the player ( \windows\player.exe ) and the full path to the video, without any quotes.

Beside the documented Fullscreen option /f, there is only one other option to play the video once /l0 (this is small-L, zero). I am just updating the documentation to add this parameter.

For example I tested the following command successfully on the command line:

\> \windows\player.exe /l0 /f \usb hd\_allsoc\video\flat.mp4

Playing multiple videos in a row does not give the best experience, as opening and closing of the player window shows as a kind of flickering.
To get a better look I recommend to implement the player code into your own application. You can either

  • Start from the PlayWnd demo application which is part of the Platform Builder.
    This is the easier approach for properly integrating the video playback into your application, or
  • I can send you the basic source code of our player.exe which is derived from that example.
    This is easier if you want to create a modified stand-alone application.

Regards, Andy

Hi

thanks, when I use your command line with the full path it works, don’t know what exactly I did wrong.
In the meantime I had a look at the source provided here (https://developer.toradex.com/knowledge-base/video-playback-wince) and got it running, so I’ll see what works best for me.

Thanks!

Hi

thanks, when I use your command line with the full path it works, don’t know what exactly I did wrong.
In the meantime I had a look at the source provided here (https://developer.toradex.com/knowledge-base/video-playback-wince) and got it running, so I’ll see what works best for me.

Thanks!