Using LM006 with Linux on Colibri imx7D

Hello,

I’m working with a Colibri Carrier Board, with a imx7D trying to make a LM006 module work.
The system is a Linux generated with Yocto from LinuxImageV2.7 Toradex Git Repository Tag

Linux Version on start: Linux version 4.1.39-2.7.2+gba2f75f

I made little modification in the device tree to also have the 7" touchscreen working.

What I can say:

  • The USB module is recognized by the Kernel. Here are the trace when plugging the module:
  • [ 705.703740] usb 1-1.3: new high-speed USB device number 5 using ci_hdrc
  • [ 705.835984] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8176
  • [ 705.842890] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  • [ 705.850255] usb 1-1.3: Product: 802.11n WLAN Adapter
  • [ 705.855252] usb 1-1.3: Manufacturer: Realtek
  • [ 705.859539] usb 1-1.3: SerialNumber: 00e04c000001

The lsusb command return the following:

  • Bus 001 Device 005: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

There is NO interface showing up when plugging the module. (Neither usb0 nor wlan0, and can not bring them up mannualy → No such device)

I tryied to follow instruction here:
http://developer.toradex.com/knowledge-base/wi-fi-(linux)#WiFi_Connection_Bring_Up_BSP_V2x

I have the following problems/errors:

  • “connmanctl enable wifi” return Error wifi: The name net.connman was not provided by any .service files
  • On the LXDE Interface, I can start connman-properties. I have an empty windows with just “Services” written, and nothing else.

Problems seems to be in the connman properties and configurations. But I do not know where to start and what to look at. Any help would be… helpfull :wink:

Thank you
Antoine

I tryied to insmod manualy the .ko
First strange thing: rtl8192cu.ko is in /lib/modules/4.1.35-v2.7b1+gc117783/ directory, while I am working with a 4.1.39 Kernel. Should I tryied a compilation from scratch to change that (I think previous version of the kernel I tested was 4.1.35)?
WHen I insmod the .ko, I have the following trace:

  • rtl8192cu: disagrees about version of symbol module_layout
  • insmod: ERROR: could not insert module ./lib/modules/4.1.35-v2.7b1+gc117783/kernel/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko: Invalid module format

Problem between Kernel version and .ko compiled version?!

Problem between Kernel version and .ko compiled version?!

Yes, issues is with kernel version mismatch.

Along with your custom kernel you will also need to build and deploy the kernel modules, information/hints regarding the kernel module build and deployment are provided in this article.

If to have your changes properly done from Yocto build you will need to add the changes in a patch and add to the kernel recipe, refer this blog post for more information.

So… I found my mistake. I was using an old rootfs because image name changed. Now when I plug the Wifi Module, I have the following trace:

  • [ 3831.973687] usb 1-1.3: new high-speed USB device number 5 using ci_hdrc
  • [ 3832.105990] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8176
  • [ 3832.112895] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  • [ 3832.120257] usb 1-1.3: Product: 802.11n WLAN Adapter
  • [ 3832.125255] usb 1-1.3: Manufacturer: Realtek
  • [ 3832.129541] usb 1-1.3: SerialNumber: 00e04c000001
  • [ 3832.346225] rtl8192cu: Chip version 0x10
  • [ 3832.429323] rtl8192cu: MAC address: 5c:f3:70:24:95:b0
  • [ 3832.434448] rtl8192cu: Board Type 0
  • [ 3832.438174] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
  • [ 3832.444060] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
  • [ 3832.457032] usbcore: registered new interface driver rtl8192cu

And the ifconfig cmd return a usb0 interface. So the driver seems ok. But…

  • Running connman-properties still show nothing!
  • “connmanctl enable wifi” still return “Error wifi: The name net.connman was not provided by any .service files”

I also have a new small network icon in the lower right. With “!” on it and “usb0 Connection has limited or no connectivity”. Cliking on repair do not do anything.

And the ifconfig cmd return a usb0 interface. So the driver seems ok. But…

usb0 is for rndis interface not for WiFi.

For WiFi ‘ifconfig -a’ output should show ‘wlan0’ interface.

“connmanctl enable wifi” still return “Error wifi: The name net.connman was not provided by any .service files”

Can you try re-flashing the stock v2.7b2 image along with your custom kernel and kernel modules.