USBO1 not responding

We have tried with various Apalis T30 on the Ixora carrier board.
USBH2 and USBH3 seem to be working fine, but we haven’t been able to detect any device connected to USBO1. We have tried in both ports X8 and X9, with and without the jumper JP2 (just for if we had misunderstood the documentation), but the port just seems not to be responding.
The system detects 3 USB ports, but the kernel does not detect any event when a peripheral is connected to that port.
The same thing happens in our own carrier board. We firstly thought it was a problem with our carrier board, but as I say we eventually tried with a brand new Apalis module and the Ixora board, and it happens exactly the same: no response from USBO1.
Of course, I don’t discard we may be doing something wrong.
Any clue of what could be happening to us?

I assume you are running our latest BSP V2.6 beta 1.

Please note that only the lower X8 port will be functional using Apalis T30 and this only if JP2 is assembled and X9 is disconnected. Alternatively one may use a prober OTG cable on X9.

Did you try booting with a device already being plugged in during boot?

We updated our system to v2.6 b1 and now it is working!!!
Maybe is there an issue with previous version of the kernel and USBO1? We find strange that no one else has reported it, but apparently is what we have to conclude…
In any case, many thanks for your help!