Usb wifi dongle problem

Dear Community:

I am trying to give wireless connection to my Colibri T30 with the LM006-1004 module. I have Linux 2.6 installed in it, but with a modified kernel to use some Gpio. I have read that to use a usb wifi adapter with a modified kernel you must build and deploy kernel modules. So I tried it like that:

I downloaded, extracted… the Linux image.

Then I compiled my new kernel.

I deployed the kernel modules to the rootfs directory with this command:

sudo -E make INSTALL_MOD_PATH=/home/ander/Documentos/Colibri/Colibri_T30_LinuxImageV2.6/rootfs/ modules_install

I get this output:

INSTALL drivers/hid/hid-multitouch.ko

INSTALL drivers/input/touchscreen/atmel_mxt_ts.ko

INSTALL drivers/input/touchscreen/fusion_F0710A.ko

INSTALL drivers/scsi/scsi_wait_scan.ko

INSTALL drivers/usb/class/cdc-acm.ko

INSTALL drivers/usb/class/cdc-wdm.ko

INSTALL drivers/usb/serial/option.ko

INSTALL drivers/usb/serial/usb_wwan.ko

INSTALL net/mac80211/mac80211.ko

INSTALL net/wireless/cfg80211.ko

DEPMOD 3.1.10-g7753763-dirty

Warning: you may need to install module-init-tools


Then I writed that Linux image to a SD card with sudo ./ command. Everything go well.

I removed the uImage file of the SD card and copied my custom kernel.

After that I reflashed my Colibri successfully. With sudo lsusb I can see that the wireless adapter is there:

Bus 002 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

But when I enter connmanctl enable wifi I get this negative response:

Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

So I don´t know what I am doing bad, maybe I haven´t understand well how to compile and deploy the kernel modules. Thanks in advance!

You’re using latest kernel code with 2.6 userspace, you should use kernel sources with git tag matching your userspace.
In 2.7b3 we moved to external wifi backports, they need to be compiled after you’ve compiled the kernel from a separate git, or you can use yocto buildsystem.

I don´t understand very good your answer because I don´t have much knowledge about this. What you are saying is that my process is bad because I used the 2.7b3 kernel userspace to my 2.6 Linux image? In that case the solution in to use 2.6 kernel version? Where I can find it?

If you can explain a bit more the process to follow…

Thanks and sorry for my ignorance.

To checkout kernel code for 2.6 release:

git checkout Colibri_T30_LinuxImageV2.6Beta2_20160701

then make sure to run

make colibri_t30_defconfig

Now you can add your changes, recompile and deploy.


By doing git checkout Colibri_T30_LinuxImageV2.6Beta2_20160701 I get this response:

error: Your local changes to the following files would be overwritten by checkout:



Please, commit your changes or stash them before you can switch branches.


That are the files I changed to use some more Gpios that were preassigned as KeyBack and KeyPower.

Do I need to change something?


You can stash the changes and apply them after changing HEAD to 2.6 tag,
git stash
do a checkout
git stash apply
or you can reset all local files with git reset --hard then do a checkout and apply required changes by hand.

Thanks. I use git reset --hard command, and recompile and deploy the modules. All went fine and works, however I don´t really understand what was bad before. Thanks again Dominik.