USB touchscreen driver

We are trying to install the drivers for a USB capacitive touchscreen (EETI eGalax 3.3.7.3825 here http://www.eeti.com/drivers_WinCE.html) on WCE7 Colibri T20.

The installation document provided by EETI suggests to create a new image with Platform Builder and VS2008. But a less cumbersome approach is suggested here: Install drivers , no need to create a new image, so we went this way.

We have successfully copied the two dll files provided by EETI ( CE7_usbtouch.dll and CE7_Touchp.dll) onto the Flash/System folder. (BTW are both needed? why? which should be referenced in the registry?).

Then modified the registry to add the following entry (I seems this should load this dll for any product from vendor 3823, EETI eGalax):

[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\3823\Default\Default\TouchKit]
DLL="CE7_usbtouch.dll"

and also tried

[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\3823\Default\Default\TouchKit]
DLL="CE7_Touchp.dll"

Upon booting up, WCE7 says nothing about the connected USB touch and the touch screen is not responsive.

BTW there were already a couple of entries under LoadClients with 3823_x as vendor… by default in
the OS image.

Any ideas?

Regards

It is now more or less clear that the path below should include both the VID and the PID of the device:

[HKEY_LOCAL_MACHINE\Drivers\USB\LoadClients\3823_29184\Default\Default\TouchKit]
DLL="CE7_Touchp.dll"

This line in the registry seems to be triggered by plugging the touchscreen.
But a dialog box still appears asking for a driver despite this line being included in the registry.

No touch input achieved yet.

@Henry,

Could you please share which WinCE version and release version you are using?

Tegra has some old settings for touch that they do not use. Before you import your registry files please go under HKLM\Drivers\USB\LoadClients and delete all the keys that start with 3823. After this import all your registry for EETI eGalax 3.3.7.3825 and Save Registry and reboot. Now touch should work.

We are using WCE7 Build 2824.

Deleted all 3823 entries from …\LoadClients in the registry.

Then we ran RegEdit on WCE and imported successfully eetiUSB.reg and eetiTool.reg (as provided by EETI). A new 3823 entry appears under \LoadClients which references USBTouch.DLL (BTW, the drivers provided by EETI are CE7_Touchp.dll and CE7_usbtouch.dll, instead).

Then we plug in the display. Nothing happens (no dialog shown asking for a driver, and no response to touch either).

Just in case, it was tried to rename CE7_USBTouch.dll to USBTouch.dll. But nothing. (Yet note that USBTouch.dll could not be deleted, it probably had been loaded upon display connection??).

I suspect that after renaming CE7_USBTouch.dll to USBTouch.dll, the driver was actually loaded.

But no touch response. And it is worrying that the driver’s file name provided by EETI need to be edited. I am not sure I am on the right track.

Dear @Henry,

Could you please download this driver package: EETI WEC7 driver.

Please import all the registry and keep other files in “\FlashDish\System”.

Let us know if that works for you. If USBTouch.dll and CE7_Touchp.dll are loading from FlashDisk but touch is not working then could you please check EET documentation to verify registry settings are proper and matching to the hardware.

@raja.tx ,

Touch is working now! Thanks.

A summary of what I did in case others might benefit.

As you suggested, I downloaded the driver package you provided (https://share.toradex.com/v5vwa0zp6z24h1y?direct), copied all the files to Flash/System. Then started RegEdit and used FIle/Import to import the three .reg files in the package. Saved Registry with the SaveRegistry tool.

Power off and on again. And voilà, the touch screen works flawlessly now.

Thank you Raja.