USB to Ethernet Adapter not working on Apalis iMX6Q

I am unable to use an USB to 10/100 Ethernet Adapter on Apalis. Have tried to create a new gadget following the basis on the USB Device Mode (Linux) article, but the device does not really work. How can I configure the adapter to work?

[   28.112880] usb 2-1.3: new high-speed USB device number 3 using ci_hdrc
[   29.156893] usb 2-1.3: USB disconnect, device number 3
[   29.462879] usb 2-1.3: new high-speed USB device number 4 using ci_hdrc
[   30.262882] usb 2-1.3: device no response, device descriptor read/64, error -71

What exact hardware (module, carrier board and USB to Ethernet adapter) and software versions of things are you talking about?

Hey Marcel.tx,
I’m using an Apalis iMX6Q module with an Ixora Carrier Board.

Software Version: Linux apalis-imx6 4.9.84-2.8.2+gb2a7f2f #1 SMP Sat Mar 31 02:44:15 UTC 2018 armv7
Have tried the same with the Apalis-iMX6_LXDE-Image_2.7 image and the device also had no response.

The adapter is a commercial model. The return message when plugged to my notebook shows it is a Realtek USB 10/100 LAN:

[ 1515.258225] usb 1-1: new high-speed USB device number 6 using xhci_hcd
[ 1515.399404] usb 1-1: New USB device found, idVendor=0bda, idProduct=8152
[ 1515.399411] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1515.399415] usb 1-1: Product: USB 10/100 LAN
[ 1515.399418] usb 1-1: Manufacturer: Realtek
[ 1515.399422] usb 1-1: SerialNumber: 00E04C36063B
[ 1515.483263] usbcore: registered new interface driver r8152
[ 1515.509553] usbcore: registered new interface driver cdc_ether
[ 1515.602649] usb 1-1: reset high-speed USB device number 6 using xhci_hcd
[ 1515.799572] r8152 1-1:1.0 eth1: v1.08.9

Thank you for the reply.

I guess you would have to find out what driver that “commercial model” is using and enable/deploy the same on the Apalis iMX6.

Well, I thought the driver was already deployed. The device is a Realtek Semiconductor Corp. RTL8152, shown in the comment. Will find out if its driver its not enabled…

We only provide the drivers of the lan adapters available in our webshop. The other drivers you have to install/compile yourself.

Best regards, Jaski

So, is it working now?

hi @heiko.kt.

Welcome to the Toradex Community.

We don’t recommend any USB Ethernet Adapters. You could choose any, which has a working driver for Linux.

Maybe the adapter is down. Check ifconfig -a.

Yes, I just had to enable the driver before compiling the kernel.

@jaski.tx As I cannot find USB Eternet adapters in your webshop, may you suggest some which are working and tested with the imx6?

I am also using and USB Ethernet Adapter on Apalis. When I plug the adapter to the USB I get this message:

[  791.624833] asix 2-1.3:1.0 eth1: register 'asix' at usb-ci_hdrc.1-1.3, ASIX AX88772 USB 2.0 Ethernet, 08:6d:41:e6:95:7f

Based on the message, a new interface eth1 was created but when I run the command ifconfig, eth1 doesn’t exist.

root@apalis-imx6:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:14:2D:4D:01:EE  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1%1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:6220 (6.0 KiB)  TX bytes:6220 (6.0 KiB)

Do you know if some extra configuration is required to be able to use the eth1?


HI @Manuel and Welcome to the Toradex Community!

Could you ask a new Question, please?
Thanks and best regards,

@qojote, You are right.

I have enabled eth1 with this command

ifconfig eth1 up