USB_C (USB_OTG1) doens't work any more with Torizon 6.x


We have been working for months with Torizon’s “imx8x-Tezi_5.7.2+build.20” and earlier versions with no problems with both USBs.

Once we have decided to go to 6, USB_C has stopped working.

I have not done more than download the new OS Image and update the path to it in the tcbuild.yaml so that it can be generated with the new image.

Just in case, I tried version 5.7.2+build.20 and the USB worked again as it did before.

Is it known if there are any changes or problems with OS Image 6 onwards related to USB_C?

These are the images that we have tried and they do not work for us:


For reference I leave a report of the lsusb command done on both images.

Hi @Germanss ,

Thanks for the detailed information!

USB should work by standard on TorizonCore images, can you please do a small test? If you install the base TorizonCore 6 image provided on Toradex Easy Installer, not adding any of your changes on tcbuild.yaml, do you face the same issue on USB?

Also, are you using the base TorizonCore image provided for us? Or are you compiling a new image using Yocto?

Best regards,
Daniel Morais

Hello Daniel, thanks for the prompt response.

I have done this test and the USB works. I have taken out from the tcbuild.yaml the following:
“custom: device-trees/dts-arm64/imx8qxp-colibri-eval-v3.dts”
I think it’s almost the same as trying to install the image directly with EasyInstaller.

I can’t figure out why this USB doesn’t work on certain versions only.

Where can I find an example to create a specific overlay of USB_OTG1 so that it always works in HOST mode?

I forgot to answer about the used image.
“Also, are you using the base TorizonCore image provided for us? Or are you compiling a new image using Yocto?”
We are using TorizonCore image directly from your website. Below is the link.

Thank you.

Hi @Germanss ,

Thanks for the information!

The issue happened because you used a device tree specific to the TorizonCore 5 version. For TorizonCore 6, you can find the instructions to download the correct device tree here. Can you please do a test and let me know if it works?

Please let me know if you have any issues.

Best regards,
Daniel Morais

1 Like

Hello @daniel_m.tx,

Yes, I have re-downloaded the devices_trees folder, branch “toradex_5.15-2.1.x-imx” and everything works as before. Thank you!

Only the GPIOs stopped working, both by code and by bash. About this I am following this topic: