USB Audio Device Not Working

I would like to test a USB Audio Hardware with my setup, and to my understanding external audio devices should work out of the box without the need to install drivers or other type of configuration.

http://developer.toradex.com/knowledge-base/audio-(linux)#USB_Audio_Hardware

However when I plug the device, and run the following command:

 arecord -D hw:3,0 -c 2 -f S16_LE -r 44100 -t wav usbin.wav

I receive the following errors:

 ALSA lib ../../../alsa-lib-1.1.2/src/pcm/pcm_hw.c:1712:(_snd_pcm_hw_open) Invalid value for card
 arecord: main:786: audio open error: No such file or directory

I thought that perhaps I was selecting the wrong device so I executed arecord -l to list all soundcards and digital audio devices. And sure enough, only the module own capture device was listed.

 **** List of CAPTURE Hardware Devices ****
 card 0: Audio [Colibri VF61 AC97 Audio], device 0: AC97 HiFi wm9712-hifi-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0

If I run arecord -l in another computer with linux and with the same USB Audio Hardware, it is recognized:

card 2: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Am I missing something or skipped some step to allow audio capture via USB audio?

I have a Colibri VF61 with the latest linux image and Iris carrier board. I may also mention that audio capture using the module own codec works, but I would like to test using a USB audio device.

Thanks in advance.

CONFIG_SND_USB_AUDIO is not enabled in colibri_vf_defconfig. Please recompile the kernel with this config option as described here and check.

This was it. I thought it was already enabled since the developer page said so, but after enabling it it worked without a problem.

Thank you very much.