USB 3.0 port vs USB 2.0 port

Hi:
I’m testing the USB port on a proto-type iMX8 board. Our iMX8 has wifi, based on the datasheet, the wifi iMX8 module only has 1 pair superspeed line which is on USBH4 pin92/94 and pin104/106. Our prototype board using USB-C connector, the superspeed line only connects to USBH4 superspeed line, and the highspeed pair connects to USBH4 D+/D- (Pin 98/100). When I connected a USB3.0 device to the USB-C port, it can identify the device on USB2.0 bus, but not on the USB3.0 bus, the USB2.0 bus seems working fine, but the device can not change to superspeed line, is there any configuration I need to change?

thank you,

Jason

Could you please provide a schematic snippets?

USB_iMX8_Interface.pdf (154.4 KB)

I put the USB connections between the USB-C connector and iMX8 module in the pdf. Let me know if you need anything else.
thanks,

Jason

Our carrier board USB SS design does not use AC coupling capacitors. Please check the Apalis Carrier Board Design Guide for details.

Can you try to connect your module to Ixora Board using USB-A SS connector (X8A)?

And why do you need an extra Wi-Fi module (apart form imbedded to Apalis iMX8 module) ?

Hi Alex, I tried to replace the caps with 0 ohm resistors, it doesn’t change anything. The USB3.0 device works fine in the Ixora board, it’s loaded on Bus2 as superspeed device, however, on our board it can only be recognized as the highspeed devices.

Hi Alex, according to the schematic of the Ixora board, it seems to me that the RX pair connected to the RX pair on the connector and TX pair connected to the connector TX pair, do I need to flip RX/TX pair on the board ? Are those supposed to be flipped in the cable?

thanks

Jason

Yes. Because they get flipped by USB cable. So connection of TXs to USN-C b1/b2 is correct but you should also wire them to a2/a3 and RXs should be also wired to b10/b11

It turns out the connector is not soldered well, half of the pins are not consistently connected.
Thanks for your help.

Jason

Thank you for the update. Glad your problem got solved.