Update glib on Colibri

Dear Sir or Madam,

in order to install a software component on my Colibri iMX8X, I need to have the libc2.33. According to the my board I currently have:

root@colibri-imx8x:~# ldd --version
ldd (GNU libc) 2.28
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

Is there a way to update from the 2.28 to the 2.33 version?

Thank you for your help.

Hi @cae30989 !

I currently have on my machine the layers for BSP 5.7.0. Looking for glibc, we can find layers/openembedded-core/meta/recipes-core/glibc/glibc_2.31.bb.

This recipe will give us:

pokyuser@90a1d76fca64:/workdir/tdxref-bsp-5/layers/meta-toradex-bsp-common$ oe-pkgdata-util list-pkg-files glibc
glibc:
        /lib/ld-2.31.so
        /lib/ld-linux-aarch64.so.1
        /lib/libBrokenLocale-2.31.so
        /lib/libBrokenLocale.so.1
        /lib/libanl-2.31.so
        /lib/libanl.so.1
        /lib/libc-2.31.so
        /lib/libc.so.6
        /lib/libdl-2.31.so
        /lib/libdl.so.2
        /lib/libm-2.31.so
        /lib/libm.so.6
        /lib/libnsl-2.31.so
        /lib/libnsl.so.1
        /lib/libnss_compat-2.31.so
        /lib/libnss_compat.so.2
        /lib/libnss_dns-2.31.so
        /lib/libnss_dns.so.2
        /lib/libnss_files-2.31.so
        /lib/libnss_files.so.2
        /lib/libpthread-2.31.so
        /lib/libpthread.so.0
        /lib/libresolv-2.31.so
        /lib/libresolv.so.2
        /lib/librt-2.31.so
        /lib/librt.so.1
        /lib/libutil-2.31.so
        /lib/libutil.so.1

And looking for supported GLIBC versions, we have:

pokyuser@90a1d76fca64:/workdir/tdxref-bsp-5/build/tmp/work/verdin_imx8mm-tdx-linux/tdx-reference-multimedia-image/1.0-r0/rootfs$ strings ./lib/libc.so.6 | grep GLIBC
GLIBC_2.17
GLIBC_2.18
GLIBC_2.22
GLIBC_2.23
GLIBC_2.24
GLIBC_2.25
GLIBC_2.26
GLIBC_2.27
GLIBC_2.28
GLIBC_2.29
GLIBC_2.30
GLIBC_PRIVATE

We have a newer version than 2.28 of your image, but not yet 2.33.

Although we can see that there are newer glibc recipes by checking OpenEmbedded Layer Index - glibc, glibc is deeply tied to everything built on a BSP.

You can try to use newer glibc, but you might break your build or (even worse) get an unstable image.

Could you share more information on why you need a newer glibc version?

Best regards,

1 Like

As a side note: BSP 6.0.0 is under development (with some releases already available), but unfortunately there is no support for Colibri iMX8X right now.

BSP 6 is using the Kirkstone branch of Yocto/OpenEmbedded, which uses the recipe glibc_2.35, which will certainly solve your request.

Best regards,

1 Like

Hi @henrique.tx,

thank you very much for your answer. I will look into the newer BSP, but I think I’d need a new hardware, since I have a Colibri iMX8X v1.0B.

I actually need a higher glibc to install a third party software that I need to try.

Kind regards.

I have another question regarding this matter, could I update my image on my current hardware version? My image right now is:

Colibri-iMX8X_Console-Image 3.0b4.254 20200421

I have a new hardware, where I tried installing the current release version of Torizon. After I upgraded the Easy Installer image, I downloaded the Torizon image and all I got was a black screen even though the installation was successful.

Thank you.

Hi @cae30989 !

I would like to ask you to create another question, as it is not related to “Update glib on Colibri” :slight_smile:

I appreciate the comprehension.

I will mark your answer as the solution, as seems like it what the solution for you.

Best regards.

1 Like