Update failed on AM62

I am trying to send an update to an AM62 but the update is failing with the following error:

SoC: AM62X SR1.0 HS-FS
Core: 143 devices, 31 uclasses, devicetree: separate
MMC: mmc@fa10000: 0, mmc@fa00000: 1
Loading Environment from MMC… OK
In: serial@2800000
Out: serial@2800000
Err: serial@2800000
Model: Toradex 0076 Verdin AM62 Quad 2GB WB IT V1.1A
Serial#: 15190385
Carrier: Toradex Yavia V1.0A, Serial# 35408102
am65_cpsw_nuss ethernet@8000000: K3 CPSW: nuss_ver: 0x6BA01103 cpsw_ver: 0x6BA81103 ale_ver: 0x00290105 Ports:2 mdio_freq:1000000
Warning: ethernet@8000000port@1 MAC addresses don’t match:
Address in ROM is 28:b5:e8:c6:e7:06
Address in environment is 00:14:2d:e7:c9:71
eth0: ethernet@8000000port@1 [PRIME]Could not get PHY for ethernet@8000000port@1: addr 7
am65_cpsw_nuss_port ethernet@8000000port@2: phy_connect() failed

Saving Environment to MMC… Writing to MMC(0)… OK
Hit any key to stop autoboot: 0
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1…
Found U-Boot script /boot.scr
973 bytes read in 10 ms (94.7 KiB/s)
-## Executing script at 90280000
7238 bytes read in 10 ms (706.1 KiB/s)
69675 bytes read in 12 ms (5.5 MiB/s)
82 bytes read in 11 ms (6.8 KiB/s)
Working FDT set to 90200000
Applying Overlay: verdin-am62_dsi-to-hdmi_overlay.dtbo
3050 bytes read in 12 ms (248 KiB/s)
Applying Overlay: verdin-am62_spidev_overlay.dtbo
560 bytes read in 12 ms (44.9 KiB/s)
10819079 bytes read in 70 ms (147.4 MiB/s)
42838710 bytes read in 247 ms (165.4 MiB/s)
Uncompressing Kernel Image
-## Flattened Device Tree blob at 90200000
Booting using the fdt blob at 0x90200000
Working FDT set to 90200000
Loading Ramdisk to 96609000, end 98ee3ab6 … OK
ERROR: reserving fdt memory region failed (addr=9cb00000 size=100000 flags=4)
ERROR: reserving fdt memory region failed (addr=9cc00000 size=e00000 flags=4)
ERROR: reserving fdt memory region failed (addr=9da00000 size=100000 flags=4)
ERROR: reserving fdt memory region failed (addr=9db00000 size=c00000 flags=4)
ERROR: reserving fdt memory region failed (addr=9e780000 size=80000 flags=4)
ERROR: reserving fdt memory region failed (addr=9e800000 size=1800000 flags=4)
Loading Device Tree to 00000000965d4000, end 0000000096608fff … OK
Working FDT set to 965d4000

Starting kernel …

[ 1.187187] pca953x 1-0021: failed writing register
[ 2.328490] mdio_bus 8000f00.mdio: MDIO device at address 7 is missing.
[ 2.346678] debugfs: Directory ‘pd:182’ with parent ‘pm_genpd’ already present!
Starting version 250.5+
[ 7.583873] ina2xx 1-0040: error configuring the device: -121
[ 7.585876] nau8822 1-001a: Failed to issue reset: -121
[ 7.624562] lt8912 1-0048: failed to find dsi host
[ 7.645052] lt8912 1-0048: failed to find dsi host
[ 7.908605] SError Interrupt on CPU3, code 0x00000000bf000002 – SError
[ 7.908634] CPU: 3 PID: 483 Comm: systemd-udevd Not tainted 6.1.46-6.5.0-devel+git.1121e06acc19 #1-TorizonCore
[ 7.908642] Hardware name: Toradex Verdin AM62 WB on Verdin Development Board (DT)
[ 7.908649] pstate: 60000005 (nZCv daif -PAN -UAO -TCO -DIT -SSBS BTYPE=–)
[ 7.908657] pc : ___slab_alloc.constprop.0+0x30/0x750
[ 7.908688] lr : __slab_alloc.constprop.0+0x30/0x74
[ 7.908695] sp : ffff80000a74b2b0
[ 7.908698] x29: ffff80000a74b2b0 x28: ffff80000987a000 x27: 0000000000000001
[ 7.908712] x26: ffff00000a0bec80 x25: 0000000000000088 x24: ffff8000087655c0
[ 7.908720] x23: ffff000000001300 x22: ffff00007fbaa650 x21: 00000000ffffffff
[ 7.908730] x20: 00000000ffffffff x19: ffff00000a0bec80 x18: ffffffffffffffff
[ 7.908738] x17: ffff800076620000 x16: ffff800009c20000 x15: ffff80008a74b38d
[ 7.908747] x14: ffffffffffffffff x13: 007473696c5f7974 x12: 696e696666615f65
[ 7.908754] x11: 0000000000000040 x10: ffff800009977a60 x9 : 0000000000000000
[ 7.908763] x8 : ffff000018a99d80 x7 : 0000000000000000 x6 : 0000000000000000
[ 7.908770] x5 : ffff800076620000 x4 : 0000000000000088 x3 : ffff00007fbaa650
[ 7.908777] x2 : 00000000ffffffff x1 : 0000000000000dc0 x0 : ffff000000001300
[ 7.908788] Kernel panic - not syncing: Asynchronous SError Interrupt
[ 7.908796] SMP: stopping secondary CPUs
[ 7.908819] Kernel Offset: disabled
[ 7.908822] CPU features: 0x00000,00800084,0000420b
[ 7.908828] Memory Limit: none

I have tried install nightly and monthly builds from torizon repos but nothing seems to be working.

Software summary

Bootloader: U-Boot
Kernel version: 6.1.46-6.5.0+git.8e6a2ddd4fe6 #1-TorizonCore SMP PREEMPT Thu Dec 21 17:08:38 UTC 2023
Kernel command line: root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.0/torizon/80b5ca9f8fb816164a3c5d5cfff2fb648f13e1c478334dad558e3c2a547e2974/0
Distro name: NAME=“TorizonCore”
Distro version: VERSION_ID=6.5.0-build.8
Distro variant: VARIANT=“Docker”
Hostname: verdin-am62-15190385

Hardware info

HW model: Toradex Verdin AM62 WB on Verdin Development Board
Toradex version: 0076 V1.1A
Serial number: 15190385
Processor arch: aarch64

Greetings @izhar.hassan,

I assume you’re doing an update using our Torizon Cloud services, correct?

Between which two versions are you doing any update?

I just tested and did an update between the 6.5.0 quarterly and the 6.6.0-devel-20240323 nightly versions and it was successful with no issues.

Best Regards,

I was updating with an older build than already installed on the SoM. I created a new build and then it worked.

I see, well glad to hear you were able to resolve things yourself.

Best Regards,