Unlock your Desktop

Hello, I want to deactivate that application. that shows when there is inactivity.

Thank you

Hello, Alan!

First, I’d like to clarify some points in order to proceed with the support:

  • What SoM and Carrier Board are you working with?
  • What image (Torizon/Yocto) and BSP are you using? In case of using Yocto, did you make any modification on your image?
  • Did you launch any other software before this application showed up?

Best regards,
Felipe Madureira

hello, thank!

i have the Apalis Tk1 and the board ixora v1.2 . i use Yocto BSP 5.

when there isn’t activity in the system, that show application “qtedscreen”.

Hello, Alan!

Probably there’s a service configured to launch this application as soon it detects user inactivity. You can identify this service and disable it, so this screen won’t show again.

In order to do that, could you type # systemctl list-units --type=service --all and # systemctl status in your target and provide us the log generated with all the services in your system?

May I ask one more question, could you inform us what company do you work for? For registration purposes only.

Best regards,
Felipe Madureira

hello, Felipe!

I can’t find it, I did what you gave me, and I can see my applications in python and qtproject2… but not the application that locks my screen.

I work for the Peruvian Navy, we are working with Toradex. :smiling_face_with_tear:

thanks you.

systemctl_list.txt (10.8 KB)
systemctl_status.txt (3.2 KB)
ps_list (4.7 KB)

Hello, Alan!

Thank you for the feedback!

I’ve installed the Multimedia Reference Image in order to investigate and reproduce the problem. Could you provide me the steps that you take in order to show up this app? Or do you just wait for the system detect inactivity?

Also, in case you close your Qt application and wait, does this windows stills show up?

I’ll do some tests on my side and I’ll let you know in case I get any results, ok?

Best regards,
Felipe Madureira

hello, thanks, I just wait it detects the inactivity.I’ve been looking for a long time how to disable inactivity…

Hello, @AlanM

I’ve to tried to reproduce it using the Toradex Reference Multimedia Image, but this window didn’t show up.

Could you provide me your image? Thus, I can probably reproduce this issue and better track its source. In this case, please send me your image by email: felipe.madureira@toradex.com

You can also use this link in order to upload your image file

Best regards,
Felipe Madureira

hello this is the link:

https://share.toradex.com/svocxm7r162awca

image

I’m running a Yocto build on an apalis tk1 ixora v1.2A board and I’m trying to stop the screen from shutting off after 15 minutes of inactivity. I’ve tried the following things with no success:

  • passing consoleblank=0 to bootargs
  • modifying drivers/tty/vt/vt.c with static int blankinterval = 0;
    Neither of these has had any effect.
    cat /sys/module/kernel/parameters/consoleblank returns a value of 900.
    My system does not have setterm.
    Please help!

Thanks

Hi @AlanM,

Can you please test if setting:

[shell]
locking=false

at the file /etc/xdg/weston/weston.ini solves this problem? These settings are probably already written there, you just have to uncomment both lines.

Best regards,
André