"Unlink of file" error while cloning linux repository

I tried to clone the linux-toradex git repository (branch toradex_vf_4.4) but I get multiple errors “unlink of file” related to /objects/fe/xxxxxxxxxxxx.temp
I googled for this issue and I found this, but I don’t understand how to get the cloning working.
Could someone help, please?

Following the article, I should clone git://git.toradex.com/linux-toradex.git.
If I do this, it works as expected.
I can’t remember where I saw the repository address, but I was using git://git.toradex.com/cgit/linux-toradex.git
Thank you

May be, you picked the cgit address instead of clone address.

May I know how exactly are you trying to clone ? Did you referred this article ?

Bad news;
after some minutes, the clone is completed successfully, but with the following strange message

warning: remote HEAD refers to nonexistent ref, unable to checkout

And so it’s impossible to checkout a branch

Which branch did you try?
What command did you use?

# git clone -b toradex_vf_4.4 git://git.toradex.com/linux-toradex.git

This didn’t worked for you ?

# git clone -b toradex_vf_4.4 git://git.toradex.com/linux-toradex.git

I use a GUI for git (Tortoisegit), but the command should be exactly this.
I’m going to try with git bash

Since my corporate firewall blocks ports needed by git protocol, I must clone using https protocol

git clone -b toradex_vf_4.4 https://....

With this option (from git bash) I get the following errors

Checking out files: 100% (52257/52257), done.
fatal: unable to checkout working tree
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry the checkout with 'git checkout -f HEAD'

That really should succeed, toradex_vf_4.4 is a valid branch. The very same command ( git clone -b toradex_vf_4.4 https://git.toradex.com/linux-toradex.git) works here flawless (git 2.11.0, altough it should work with any git version). Try check out again with

git checkout -f toradex_vf_4.4

What host OS/version are you using? What git version?

The process of cloning is quite slow (more or less 40 minutes); at the end I get the same message.
If I try git checkout -f toradex_vf_4.4 I get the following message

$ git checkout -f toradex_vf_4.4
fatal: Not a git repository (or any of the parent directories): .git

I use git 2.11.1 under Win 7 SP1 64 bit.

Yeah we don’t use Windows here for Linux development, we always use Linux. Not sure why that fails on Windows, it must be an issue related to Windows or the Windows version of git.