Unified MultiTouch Driver not loading not

Having installed the Unified Multitouch driver
it does not load on boot
all Registry settings are correct
sometime it will boot once then never again

How did you determine that the driver was not loaded?

we know the status of the driver by using the dbg.Serial output on a terminal
on boot if it loads we get UnfdMutiTchDrv 2.0 loading…done
if it dosent load we get nothing no error
until we try and load the HwAdapt then we get an error
MultiTchHwAdapt loading…no Unified Touch Driver…aborted

this loads and works with a new module then for no reason will just stop working
we have the touch screen running it is calibrated then the driver just stops loading
nothing seams to rectify this until I re flash the module


it appears to stop loading if I run the I2C tool (scan the bus)
I have re flashed 3 modules and it loads every time until I run the I2C tool and never loads again after that

@Malc and @alex.tx - we are having the same issue here as well!

The unified driver works only for a short while, after a clean image install and driver install. Then it stops loading. Have you found a solution?

We are on iMX7D 512 with WEC7.

Thanks for your support!

I still don’t understand your issue. What does it mean “Then it stops loading”? Are you getting any error messages when you trying to load driver? How you define that it was not loaded? Which display/touch controller are you using? Can you describe a repro steps in details?

We are using the FT5x06 controller.
After we installed the Unified Multi-Touch Driver, both drivers (Unified and the Adaption Driver) worked.

But after a few reboots, the Unified Multi-Toch Driver is no longer loading. Unfortunately I have no steps to reproduce.

I checked the debug output during boot and could not find any error. No attempt is made to load the driver, so the line “UnfdMutTchDrv 2.0 loading…done” does not appear.

Below you find the debug output in the case where its not loaded:

OEMLaunch: 0x80180000

Toradex Windows CE 7.0 1.2 for iMX7 Built Feb  1 2019
SMP support enabled
CPU0 started
CPU1 started
Loading ALPCD...
Done Loading ALPCD (0 ms)
Loading SDBusDriver...
Done Loading SDBusDriver (1 ms)
Loading TAPI...
Done Loading TAPI (1 ms)
Loading WAPIMAN...
Done Loading WAPIMAN (6 ms)
Loading SmartCard...
Done Loading SmartCard (0 ms)
Loading ccfgsvc...
Done Loading ccfgsvc (0 ms)
Loading SIP...
Done Loading SIP (5 ms)
Loading NTLMSSP_SVC...
Done Loading NTLMSSP_SVC (0 ms)
Loading PXP...
Done Loading PXP (0 ms)
Loading FlashDisk...
Loading NAND...
Done Loading NAND (14 ms)
Done Loading FlashDisk (16 ms)
Loading COM1...
Port is used for OS debug! 
Failed(0) Loading COM1 (1 ms)
Loading I2C1...
Done Loading I2C1 (5 ms)
Loading I2C4...
Done Loading I2C4 (53 ms)
Loading COM2...
Done Loading COM2 (2 ms)
Loading COM3...
Done Loading COM3 (1 ms)
Loading Audio...
Done Loading Audio (84 ms)
Loading CredSvc...
Done Loading CredSvc (69 ms)
Loading Netbios...
Done Loading Netbios (0 ms)
Loading USB_OTG2...
Done Loading USB_OTG2 (306 ms)
Loading NDIS...
Loading ENET1...
Ethernet: Disconnected 
Done ENET1
Done Loading NDIS (101 ms)
Loading USBOTG...
Done Loading USBOTG (95 ms)
Loading SD Card...
Done Loading SD Card (379 ms)
Loading AFD...
Done Loading AFD (77 ms)
Loading Ws2Serv...
Done Loading Ws2Serv (0 ms)
Loading PPP...
Done Loading PPP (5 ms)
Loading NDISUIO...
Done Loading NDISUIO (2 ms)
Loading Autoras...
Done Loading Autoras (1 ms)
Loading NdisPower...
Done Loading NdisPower (2 ms)
Loading Ethman...
Done Loading Ethman (0 ms)
Loading NSIPROXY...
Done Loading NSIPROXY (0 ms)
Loading EAP3SVC...
Done Loading EAP3SVC (1 ms)
Loading NSISVC...
Done Loading NSISVC (1 ms)
Loading EAP3SVC...
Done Loading EAP3SVC (0 ms)
Loading CmService...
Done Loading CmService (105 ms)
Loading Display driver...
Invalid Bpp value used. must be 16, 18 or 24.
Done Display driver
+OEMSetRealTime(2006/1/1 13:0:12.803)
+OEMSetRealTime(2001/6/19 18:10:38.000)
RTC Time restored (20.06.2001 01:10:38)
Ethernet: Connected at:  100Mbps full duplex
+OEMSetRealTime(2001/6/19 18:10:39.415)
Loading NETUI...
+OEMSetRealTime(2001/6/19 18:10:39.762)
+OEMSetRealTime(2001/6/19 17:10:39.767)
+OEMSetRealTime(2021/2/11 7:5:12.000)
RTC Time set (11.02.2021 15:05:12)
MultiTchHwAdapt loading...no Unified Touch Driver...aborted
Got a valid IP Address:
+OEMSetRealTime(2021/2/11 7:5:22.000)
RTC Time set (11.02.2021 15:05:22)
Loading NETUI...
MultiTchHwAdapt loading...no Unified Touch Driver...aborted

I’m very sorry, but I can’t investigate an issue if there is no way to reproduce it.

@alex.tx unfortunately, we have not yet found a way to reproduce the problem reliably.

Therefore we use a workaround in the meantime:

We have changed our hardware adaptation driver so that the touch events are no longer passed on to the unified driver but we now trigger the corresponding mouse events ourselves.

Perfect that you have found a workaround. Let us know if you need any help.
Best regards,