Unidentified USB Device

I’m using USB touch screen for my application. I already have dll drivers. But everytime I boot the device, it asks to enter name of driver.

Unidentified USB device. Enter the name of driver for this USB device.

I have kept driver at location ‘My Device’

Any solution for this problem.

Could you please provide more details about your case?

  • Colibri iMX7 SKU and its HW version
  • WinCE version and its BSP version
  • Link to touch driver
  • Exact error message about missing driver
  • Please enable debug messages over the serial port and collect full log starting from boot.

1)Colibri IMX7D 512MB V1.1D
2)Windows CE 7.0 1.2 for iMX7 Built Feb 1 2019, BSP ver 1.2
3) Link

  1. No any error on serial port.
    log.txt (2.0 KB)

@alex.tx Any updates? I have tried adding dll files in FlashDisk\System. And importing related reg files.

When i insert USB after complete OS loading, then no popup occurs. But when i start while USB plugged in, this pop up comes. I have checked the following,

“Dll”=“BusEnum.dll” is already there.

The above procedure works fine for VFxx.

Hi @kshah ,
Can you try adding “Wait4FlashDisk” registry as mentioned here in your touch driver registry settings.

Hello @sahil.tx,
Tried this also. But no change. It is still showing same.

I tried on one more IMX7D 512MB. I don’t know how but it worked( without adding Wait4FlashDisk").

So tried clearing reg of old device, updating windows and then reimporting all setting. Still it didn’t work.
Also also tried exporting all reg setting of working module and then importing it to non working module. But still no change. Pls see here working module reg settings.
all reg.reg (925.4 KB)

Pls see attached dbg info during booting.

non working boot dbg info.txt (2.2 KB)
working module boot dbg info.txt (2.4 KB)

Which DLL have you added and what registry changes you’ve done? Instructions from driver link you provided suggest to rebuild WiNCE image using Platform Builder. Have you done that?

Hello @alex.tx,

I do not want to go with image rebuilding process.

I have added TwTouch.dll, and imported TwTouch.reg and TwParams.reg

You may also need to install the dll from the Control Panel folder. Especially all TwIO_xxx.dll
And it’s better to ask 3M how to correctly install their driver without recommended system rebuild.

Dear @alex.tx ,

If you could go thru above communication with @sahil.tx , you could find, process I’m trying already works good in VFxx. So its IMx7 module issue only which can be resolved by Toradex.
We had 2 modules of IMX7. Above process is working on 1 module, and not working on 2nd module.