Unable to use USB mouse and keyboard on Ixora carrier board

I have purchased Ixora carrier board and Apalis TK1. Only the top USB connector on X8 is getting detected and there is no power on bottom X8 USB connector as well as no power from the X7 USB connector. I tried the jumper settings on J2 and J3, but no use. The two USB connectors are not getting detected/no voltage coming out of the ports.
Can i know what settings are to be made?

Thanks and regards,

I’ve tested Apails TK1/ Ixora with Linux For Tegra Image 2.8 image and all 3 mentioned connectors work OK with my mouse. The J2 should be closed to make lower part of X8 works as a host. J3 is for UART and has no affect on USB

Which image are you using?

Actually i have still not loaded any OS. I have inserted the pen drive having apalis OS setup on X8 top side connector. I have inserted mouse on the lower X8 connector. I have even closed the J2 jumper. Still it is not able to detect the mouse so unable to proceed with OS setup.
What is the problem now? Is it the problem with the board?

Thanks and regards,

HI @sv_nagendra

i have still not loaded any OS

So how do you know that USB mouse is not working?
Did you boot up Toradex Easy Installer? If yes, which version?

Still it is not able to detect the mouse so unable to proceed with OS setup

You can make a VNC connection to your board and install the OS remotely?

Best regards,