Unable to Stop U-Boot with the i.MX6ULL image on a Viola Board

I work with thw Viola Board V1.2B and use an i.MX6ULL with the Image:Colibri iMX6ULL (2.8b4 | 2018-10-05)
The UART connection the the terminal on the Linux Host works fine.

Problem:
I cannot stop the U-Boot with any key on boot phase ?

What can be the reason ? (Ii seems do be no hardware problem, because Terminal works fine with UART)

hi @StefanR

Could you provide the version of the hardware of your module?

Please share also a picture of your setup (Uart connection) ? Thanks.

You could also try to increase the boot delay with the following command from linux:
fw_setenv bootdelay 10

Best regards, Jaski

Set the hardware flow control to “No” in minicom

Thanks for you Input.
@StefanR: Did this solution work?

I don’t know if it worked for the person who asked this question, but for me it worked perfectly with my Apalis and iMX6 board. Thanks a lot

Perfect that it works. Thanks for your Input.

I also have an issue with this. Something similar, but mine is stuck at the kernel (…because it’s bad)
The problem is I can’t get to stop the u-Boot before to change the environment (bootdelay) either to reflash the image … because of the process… it’s not finishing…

I did a try with the minicom - “hardware flow control - No”
But nothing happened…
Should I press repeatedly a button or holding it or keystrokes maybe or ??

Any comment may help! I would very appreciate in advance!

alt text

HI @r4nd3l and Welcome to the Toradex Community!

Could you ask a new Question and provide a serial boot log in text format?

Thanks and best regards,
Jaski

Hi @jaski.tx
Thanks for your response!

I posted the my issue here:
https://www.toradex.com/community/questions/43573/stuck-after-the-kernel-is-load-unable-to-escape.html