Unable to start x11 on core-image-x11 yocto image

I trying to get a linux image with x11 support on a imx7d colibri board. I’m building successfully core-image-x11 image recipe in the yocto enviroment. I succesfully booted the image but after login x11 server does not start furthermore I do not have startx nor xinit commands and xhost giving me this error:

xhost: unable to open display ":0.0"

I think I am missing something in the configuration of the image, can you please help me?

This is my current “conf/distro.mydistro.conf” setup

require conf/distro/tdx-x11-upstream-rt.conf
DISTRO_FEATURES:append = " x11"
DISTRO_FEATURES:remove = " wayland pulseaudio wifi 3g nfc alsa bluetooth"
MACHINE_FEATURES:remove = " alsa touchscreen wifi bluetooth 3g qemu-usermode"


Hello @franz-retfie,

Welcome to the Toradex Community!

I see you using the tdx-x11-upstream-rt.conf distro as a base.
Do you need the PREEMPT-RT patches?
If not, for the Colibri iMX7 on BSP 6 it would be recommended to use the tdx-x11-upstream.conf distro as a base for your custom distro.

There is also no need to add x11 or remove wayland from the distro features, this is already done in the tdx-x11.conf file, which is used by all tdx-x11 distros.

You are also building the core-image-x11, which is not a supported target.
It would be recommended to use one of the Toradex Reference images.
In this case, the tdx-reference-multimedia-image would be a good starting point.
With this image working, you can remove what you don’t need for it and create your custom image.

Best Regards,

thank you for the suggestions.
I was able to start x11 using tdx-x11-upstream-rt.conf and tdx-reference-multimedia-image as you suggested. I didn’t say that in the initial post but I need the PREEMPT-RT patches so I’m using the -rt conf.
However I did find another problem during the process: I found a wrong setting in /etc/X11/xorg.conf, so I changed it to this:

Section "Device"
        Identifier "i.MX Accelerated Framebuffer Device"
        Driver "fbdev"
        Option "fbdev" "/dev/fb0"
        Option "SyncDraw" "false"

Hello @franz-retfie,

Thanks for sharing this information.

Best Regards,