Unable to start snmpd in IMX6

Unable to start snmp in imx6 sbc on lxde. I followed following steps but getting error" Error opening specified end point "

1.Download SNMP Liberary (It is already in backup folder)

2.Extract tar file
ex: tar -xvzf net-snmp-5.7.3.tar.gz

3.Copy .c .h Agent files (mib.c,mib.h) to ~/net-snmp-5.7.3/agent/mibgroup/

4.Start config for liberary
./configure --exec-prefix=/usr --enable-static --disable-shared --enable-mini-agent --disable-applications --disable-des --disable-privacy --disable-md5 --disable-manuals --with-ldflags=-Bstatic --with=-lrt --with-cc=/home/teja/gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux/bin/arm-linux-gnueabihf-gcc --with-ar=/home/teja/gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux/bin/arm-linux-gnueabihf-ar --with-ld=/home/teja/gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux/bin/arm-linux-gnueabihf-ld --with-endianness=little --build=i386-linux --host=arm-linux --target=arm-linux --without-openssl --with-logfile="/var/log/snmpd.log" --with-default-snmp-version=2 --disable-mib-loading --without-perl-modules --disable-embedded-perl --with-mib-modules= (ex: jisnuAUPCmib)

5.Start buliding the library

make 
make install DESTDIR=<folder_path>(ex : /home/net_snmp_fnl)

6.Copy compiled files to target (i.e SBC)
scp -r <folder_path>/usr/ root@192.168.1.12:confused:

7.To start or test snmp
snmpd -f -L -Dxyzmib (with debugging enabled)
snmpd (without debugging enabled)

8.Modify the /usr/local/etc/snmp/snmpd.conf on target as example file (snmpd.conf) in backup folder
i.e add the community string (rwcommunity xyz default .1.3.6.1.4.1.38712)

9.Copy snmpd.sh (startup demon script) to /etc/init.d on target

10.Add init script to startup
update-rc.d snmpd.sh defaults

HI @vineeth

Where did you get this snmp library? Do you have any error logs?

By the way, snmp can also be installed using opkg install net-snmp.

Best regards
Jaski

Got the library from net snmp and complied for imx6…Yaa i have error logs.alt text

Hi

Reading all console message may help. I guess that the server stops because it is missing needed configuration. Running the proposed command might fix your issue.

However why do you not just install net-snmp from the angstrom feeds as Jaski proposed?

For the snmp client and server:

opkg update
opkg install net-snmp
opkg install net-snmp-server

And be done with.

Max

P.S. Note that copy / past text from console output is preferred over sending screenshots.

While commands:
opkg update
Error coming : wget bad address ‘feed toradex.com
Collected errors
Failed to download http:// feed.toradex.com.

Do you have your board connected to internet? If yes - please check your company firewall settings.

Problem closed. Solution copy the snmpd.conf in/usr/local/etc/snmp.

Thanks for the feedback. Where did you get the snmpd.conf file?