Unable to put Colibri T20 into recovery mode

I have a Colibri T20 board, which I got from previous owner. It has a Windows CE 5.0 image installed with previous owner’s application. I also have Colibri Evaluation Board v3.1. My host PC is running Fedora.
I need to flash a Linux image to the T20 board, but I have trouble entering the recovery mode.
I tried to enter recovery mode following instructions at the txx-recovery-mode. However, none of the methods described there worked for me.
If I follow instructions to enter recovery mode using recovery and reset buttons on Evaluation Board and then press Power button, it just starts booting Windows CE normally. Same goes for short circuiting method: I connect correct pads, plug in power supply, press Power button, release the circuit and it just boots normally.
The only way described methods affected something was when I powered on the board, it started booting normally, and then I used recovery and reset buttons method, but I did not get into a recovery mode as a result, only got a black screen with no reaction to inputs.
I tried all of the described methods with my PC connected to both X27 and X29 USB ports. Jumpers 17 and 19 are set to USB mode.
Serial console methods also do not work, the board does not output anything to it and does not react to any inputs from it.
Am I missing something important in the instructions?
Is it possible that previous owner somehow messed up the recovery mechanism and/or erased memory segment containing recovery mode? What can I do then?

Dear @dimas,

Welcome to our community. Please feel free to roam around and search for content here.

About your points, I’d like to clarify a few things and ask additional questions to toggle your issue.

Did you check the following point on your host machine as stated on the page you mentioned Txx Recovery Mode | Toradex Developer Center?

  • Disable the High-Speed mode (EHCI driver) on your development PC. If you are a Linux user have a look here

You shall not press Power Button after that. If you do so, the module will not enter recovery mode. The procedure would be:

  1. Turn off the board.
  2. Press and hold the Recovery button
  3. Press the Reset button while still holding Recovery
  4. Release the Recovery button after a few seconds after releasing reset

Is this the procedure you’re following?

Even though X27 and X29 ports have the same USB cable connection, they aren’t connected to the same pins on the module so you should use X29 as stated in the article.

Could you please confirm the procedure you’re following before we could go further?

Finally, could you also please share with us the serial number of this module?

Best regards,

Thanks a lot for your help. I successfully put my board into recovery and installed Angstrom LXDE image to it.
I actually managed to put my T20 into recovery with following steps:

  1. Connect board to host PC via X29
  2. Power ON the Evaluation Board (by that I mean power on button, not just plugging it in)
  3. Press and hold recovery button
  4. Press reset button
  5. Release recovery button
    ^ These steps put the board into black screen / no response mode, after which I could run update.sh on my host PC and it did actually launch U-boot on board.
    After that, I plugged my PC into X27 port, which allowed me to interact with my board via serial terminal. For some reason, U-boot prompt did not respond to my keyboard.
    Then I flashed Linux image with steps described here Flashing Embedded Linux to Tegra Modules
1 Like