Unable to open ADC

With prebuild image imx6_wince7bsp_1.6-20191223 ADC works great.
When I build image using imx6_wince7workspace_1.6-20191223 and imx6_wince7bsp_1.6-20191223
ADC fails to open.

Here is the code snippet.

I am using TdxAllLibraries (toradexcelibraries_2.3-20181011), Both release and debug version fails.
I tried ADC_demo (vcsharp_adc_demo_v1.0), it also fails, here.

Please help.

Dear @piseek,

Could you upload your build image here or https://share.toradex.com/.

Could you try to enable the debug message and log it during the issue occurs then share it with us.

Here is the image

and here is the log.
Look for “Unable to open ADC1”, this is the point where it tries to open ADC1.

Thank you for fast response.

Dear @piseek,

For a quick try, Could you disable RTCSync by rename or deleting the RTCSync registry here : https://developer.toradex.com/knowledge-base/rtcsync#using-a-customized-rtcsync-tool.
As I am seeing RTC failure debug messages below

RTC reported oscillator failure
Invalid time on External RTC, please set a valid time

If it works after disabling RTCSync then there is a problem in the RTCSync tool configuration.

Could you write more detailed about how you are planned to use RTC? We have documented RTC feature available from the SOM and software usage here : https://developer.toradex.com/knowledge-base/rtc

I disabled RTC as you suggested, now there is no RTC failure, but the problem with ADC remains.

The problem was with TdxAllLibrariesDll.dll from Toradexcelibraries_2.1.
The one from Toradexcelibraries_2.3 works.

That is also the reason why ADC worked with prebuild image - I added the dll (2.3) in windows folder.
With custom image, the dll (2.1) was already included. I did try to replace it with newer version, but that can not be done, even tho the windows prompts you to confirm the replacement.

Raja thank you for the effort.