Unable to Install APX Driver for TK1

We use the Apalis T30 module with WinCE. Now I wanted to evaluate Torizen or the TK1 module for the future and have the problem that Windows calls the driver for the module incompatible. So I unpacked this morning the TK1 module, put it in a Ixora carrier board and I can see the APX device in the Device Manager:


But no driver is accepted as compatible. I tried the driver from Toradex Documents - NVFlash / Recovery Toolset

With a T30 module and the same Ixora board the recovery mode works without problems.

Did the test with Ixora V1.0A and V1.1A. So I can exclude a problem with the Ixora board.
I only have one TK1 module and can’t test another more.

Is it possible that the TK1 module is broken?

Hi @TriUrs

Thanks for writing to the Toradex Community!

For installing Torizon, you could use Toradex Easy Installer. Regarding the recovery mode, please have a look here.

Best regards,

Hi @TriUrs

I am running into the same problem for the TK1 on Windows 10 recovery mode.
Ixora V1.1A carrier.
Did you find a solution or files that worked for the APX drivers?
I tried the NVFlash files that @jaski.tx posted in the link, but drivers are still not recognized.
Any help would be appreciated.


Hi @TriUrs, Hi @Josh

Currently it is not possible to flash image on Apalis TK1 using Toradex Easy Installer on Windows. We recommend you to use Linux on virtual machine or docker or native Linux to flash image on Apalis TK1.

Anyway, if you want to do development for Apalis TK1, you will need Linux on your Host.

Best regards,