Unable to go into UBOOT

Dear Community,

I am unable to go into UBOOT. I have previously logged in without any issues. But the countdown time for autoboot is very quick.

Kindly provide a solution.

hi @narayanamohan

There is a uboot parameter bootdelay, whose value can be set to a value in seconds for the delay you want. Usually in our official releases this delay is set to value of 1.

For you issue you, maybe you set this value to 0. You could launch the minicom connection and then you can also keep pressing CTRL + C.

This should work and once your are in uboot, you could change the bootdelay value.

Hi Jaski

Thanks for the reply. I tried using minicom and pressing CTRL+C but unable to go into U-BOOT.

Can you suggest any alternate solution?

Another issue we are facing is after booting we are getting the error message.
Provided in the image.

alt text

Can you type in the console or not? I could not read the image you provided, could you share this again?

What are your port settings for minicom??

Kindly find answers for your questions

Can you type in the console or not? No i am Not able to type in console.

could you share this again? I have attached log file below

link text[link text][2]

What are your port settings for minicom??

If you cannot type in the console, this might be a cable issue. Could you try a different cable? Are you using the Toradex Starter Kit?

Please share also an image showing the connection of the cable on iris board?

I’ve rechecked the cable. Does’nt Seem to be a problem.

Also checked Serial to usb converter with docklight.

I have worked on this connection previously and have use UBOOT successfully
I have attached pics of board connecting to serial connection.
alt text
link text


Thanks for those files. There is already a RS232 Transceiver on the Iris Board and you don’t need to convert the signals coming from usb to rs232 converter to the TTL Level. Connect those signals directly to the Iris Board.

As per your instructions.

I tried removing TTL converter and connected my signals directly to board.

I am still not able to log in to UBOOT.
Boot time is very short.

But able to type after boot process is complete.
I am able to login to root now.

Could you please post a complete boot log as a textual file? Should you have any of our regular demo images installed you may use fw-utils to increase the boot delay e.g. as follows:

fw_setenv bootdelay 10

I have set the boot delay command and now i am able to use UBOOT.

Thanks for your valuable help and support.

link text I have attached the log.

There is still this message showing up recently about ethernet.

The Angstrom Distribution colibri-imx7-emmc ttymxc0

Angstrom v2016.12 - Kernel

Colibri-iMX7-eMMC_LXDE-Image 2.7b4 20171004 colibri-imx7-emmc login: [ 8.271319] fec 30be0000.ethernet eth0: Link is Up x
[ 8.279283] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Kindly provide details about this.

That just means that you successfully did get an Ethernet link. Nothing wrong with this. Or is there any issue with Ethernet?

Perfect that it works. Concerning the Ethernet, the module just reports that the eth0 link is ready which means the module is connected correctly to Ethernet. There is no error.

Thanks@ jaski and marcel for the help.

As expected it is working.

I will get back if i have any queries.

Perfect. Thanks for the feedback.