Unable to get linux USB networking working on Apalis imx6

I’m unable to get windows 10 or Ubuntu Linux to recognize the rndis/usbg/usb0 device. I’m attaching the output of “systemctl status usbg.service” and “journalctl -b”.link text

As you’ll see, systemctl status reports it as “inactive (dead)”. journalctl has it enabled, then not ready, and it never becomes ready.

connmand ignores it but I understand usb0 is blacklisted on connman so that networkd can handle it.

Thanks for any help!


Hello Mike

Welcome to the Toradex Community.

Which carrier board are you using? How did you connect the module/carrier board to the your Host, directly or through a Usb Hub? Are u using USB3.0 or USB2.0?

The carrier board is an ixora. The connection was direct, a USB A-micro cable between the ixora connector X9 and the host computer USB-A. Jumper JP2 was removed to enable OTG and disable X8. The host machine was almost certainly USB3, but I have a USB2 hub I can insert if USB2 is required.


Hi All,
I tried a different (but essentially identical, both were recently restored from the same backup) Toradex, and RNDIS worked as advertised without problems with a Windows 10 machine as well as Ubuntu. The USB2 hub was not needed, even though I was using a SS USB port on the PC.

Consequently I think we can close out this question, though I will still eventually need to figure out why the first Toradex wasn’t working.

Dan Martin

Hi Dan

Perfect, that it worked. Thanks for the feedback.