Unable to flash linux image from scratch

Hi all,
My final goal is to flash a custom version of linux & u-boot built with ptxdist.
But at the moment I am unable to flash even the standard image. I’m following the guide found here.
I downloaded the image Apalis-iMX6_LXDE-Image_2.7.4 (2018-01-07 23:12).
I used the “sudo tar …” command in order to extract all the files that were copied to an USB stick.
I plugged the USB stick into the evaluation board and reset.
I reset again the shorten the PINs in order to enable the recovery mode. In fact, with the command lsusb I was able to see 15a2:0054 NXP/Freescale Semiconductor, Inc..
From the image directory, I launched the command ./update.sh -d -m 1.

$ ./update.sh -d -m 1
Apalis iMX6 rootfs specified
[sudo] password di user: 
config file <./imx_usb.conf>
vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf
vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf
vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf
vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf
vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf
vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf
vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf
vid=0x066f pid=0x37ff file_name=linux_gadget.conf
config file <./mx6_usb_work.conf>
parse ./mx6_usb_work.conf
15a2:0054(mx6_qsb) bConfigurationValue =1
Interface 0 claimed
HAB security state: development mode (0x56787856)
== work item
filename ../apalis-imx6_bin/u-boot.imx-recover
load_size 0 bytes
load_addr 0x00000000
dcd 1
clear_dcd 0
plug 1
jump_mode 2
jump_addr 0x00000000
== end work item
main dcd length 310
sub dcd length 30c

loading binary file(../apalis-imx6_bin/u-boot.imx-recover) to 177ff400, skip=0, fsize=55c00 type=aa

<<<351232, 351232 bytes>>>
succeeded (status 0x88888888)
jumping to 0x177ff400

Via serial console, I stopped u-boot when asked.

U-Boot 2016.11-2.7.4+g1b121c6 (Oct 05 2017 - 04:30:11 +0000)
CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
Reset cause: POR
I2C:   ready
DRAM:  2 GiB
PMIC:  device id: 0x10, revision id: 0x21, programmed
auto-detected panel vga-rgb
Display: vga-rgb (640x480)
In:    serial
Out:   serial
Err:   serial
Model: Toradex Apalis iMX6 Quad 2GB IT V1.1C, Serial# 05146573
Net:   using PHY at 7
Hit any key to stop autoboot:  0
Apalis iMX6 #

Finally I tried to update, forcing the use of usb (with setupdate I got the same result).

Apalis iMX6 # run setusbupdate
starting USB...
USB0:   Port not available.
USB1:   USB EHCI 1.00
scanning bus 1 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found
4261 bytes read in 172 ms (23.4 KiB/s)
## Executing script at 12000000
enter "run update" to update the entire module
Apalis iMX6 # run update
switch to partitions #1, OK
mmc0(part 1) is current device

MMC read: dev # 0, block # 138, count 1 ... 1 blocks read: OK
** File not found apalis_imx6/u-boot.imx-spl **
** File not found apalis_imx6/mbr.bin **
** File not found apalis_imx6/boot.vfat **
** File not found apalis_imx6/uImage **
** File not found apalis_imx6/imx6q-apalis-eval.dtb **
** File not found apalis_imx6/root.ext4-100 **
switch to partitions #0, OK
mmc0(part 0) is current device

MMC write: dev # 0, block # 40960, count 0 ... 0 blocks written: OK
resetting ...

At this point the module won’t boot, no messages or infos.
I’m newbie in this world and I can’t figure out how can I install neither the standard version nor the custom one.

Can you help me to find the error?
Many thanks in advance,

… I used the “sudo tar …” command in order to extract all the files that were copied to an USB stick. …

No, you need to generate the update media as outlined in the Preparation section further up in that same article e.g. doing ./update.sh -o /mnt/usbstick.

You are right, now the standard version boots.
Next step: understand how to install my own version.

Many thanks,

You are very welcome.

BTW: For deployment as well as recovery we do recommend using our new Toradex Easy Installer very much easing the whole process (e.g. there you may just extract a package to your favorite storage device, plug it in and off you go).

Probably was my fault, but it doesn’t recognize my custom image. I used it in order to install a standard version but then I made a mess and I was not able to run it anymore.
So I tried with the procedure via shell.
I will try to restore it.
Thanks, regards.

You are very welcome.