Unable to disable the xterm terminal window (TXD-X11)

Hi All,

We are trying to customise & build the Linux OS image, based on the TDX-X11.
As part of the start-up behavior, we want to disable the x-term (terminal) that comes on boot-up, as would be starting our own UI app.
We are seeing the x-term before our application starts and unable to disable it by forcibly killing the process, as it keeps respawning.
Could any suggest what is the best method to complete disable the x-term/terminal on startup?
We still need the x11 to work for our application, but do not want to have the terminal shown up on the screen (please see the attached image for reference).


Hi @gbharath,

Thanks for posting your query. Can you please also provide below information to completely understand your requirement and issue:

  • complete software and hardware version detail (BSP, Module and carrier board)

  • What are the changes you have done to stop xterm?

e.g if your image is based on tdx-reference-multimedia, try removing xterm from meta-toradex-demos/recipes-images/images/tdx-reference-multimedia-image.bb

    ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
                         'weston weston-init weston-examples ${APP_LAUNCH_WAYLAND}', '', d)} \
    ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
                         'weston-xwayland xterm', \

Best Regards
Ritesh Kumar

Hi @ritesh.tx
Thanks for your feedback.

Hardware details: Col. IMX6ULL 256MB , V1.1A (07012355)
Linux Kernel Info - 5.4.193-5.7.1-devel+git.f78299297185

We have tried the below:

  1. Force killing it on boot-up, but it kept on respawning & it seems like the xterm is configured as a service with systemd & it keeps starting again.
  2. Tried removing the service from systemd, but we may not have done this correctly as this wasn’t also working.

As per you suggestion, we have also tried now by removing “xterm” from the “oe-core/layers/meta-mach/recipes-images/images/tdx-reference-minimal-image-mach.bb”. This also didn’t work.

Let me know if you require any further info.


Hi @gbharath ,

Thanks for trying, to reproduce your environment we tried with below version of image, here we are able to see application(analog clock) starting without any xterm window.

root@colibri-imx6ull-06398948:~# cat /etc/os-release 
VERSION="5.7.2-devel-20230620070457+build.0 (dunfell)"
PRETTY_NAME="TDX X11 5.7.2-devel-20230620070457+build.0 (dunfell)"
root@colibri-imx6ull-06398948:~# uname -r 

To further check we will need all the changes you made while customising image. If you are not comfortable sharing changes on community, then write us to support.in@toradex.com.

Additionally you can check what all service are enabled on device with below command

systemctl list-unit-files --state=enabled

Best Regards
Ritesh Kumar