Unable to bundle the containers "invalid mount config for type "bind": bind source path does not exist"


We are developing our application using Visual studio code IDE(with Torizon extension) and creating a custom build image using torizon-core builder tool.
Here, After building the release container and pushing to docker registry, we are exporting the release version"docker-compose.yaml" using Torizon: export docker-compose file command and using that docker-compose file to create the custom build image. attached the docker-compose file for your reference.
docker-compose.yml (967 Bytes)

We following the below link to create a bundle and build the custom image with docker container’s,


Pre-provisioning Docker Containers onto a Torizon OS image | Toradex…

Here, recently when we tried to bundle the container images, we are getting the below mentioned error message and previously it didn’t show any error like this. Please resolve this problem.

> saikrishna@BPLM0025:~/tcbdir_6_5$ torizoncore-builder bundle docker-compose.yml --bundle-directory bundle --platform linux/arm/v7
> Creating Docker Container bundle...
> Starting DIND container
> Stopping DIND container
> Error: container images download failed: 400 Client Error for http+docker://localhost/v1.44/containers/create?name=tcb-fetch-dind: Bad Request ("invalid mount config for type "bind": bind source path does not exist: /home/saikrishna/tcbdir_6_5")

Software summary
Bootloader: U-Boot
Kernel version: 6.1.71-6.5.0+git.38fb82ecd144 #1-TorizonCore SMP Tue Dec 19 14:52:07 UTC 2023
Kernel command line: root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.0/torizon/91c83892a0379fb2e0b10cc10b2247d7594da663c35f251db6a69b1f54986eaa/0 console=null
Distro name: NAME=“TorizonCore Upstream”
Distro version: VERSION_ID=6.5.0-build.8
Distro variant: VARIANT=“Docker”
Hostname: colibri-imx7-emmc-14952882

Hardware info
HW model: Toradex Colibri iMX7D 1GB (eMMC) on Colibri Evaluation Board V3
Toradex version: 0039 V1.1B
Serial number: 14952882
Processor arch: armv7l


Greetings @Saikrishna,

Could you provide more information about the machine where you are running TorizonCore Builder. Is this a Linux or Windows/WSL machine? What version of Docker Desktop/Engine are you running on this machine?

The reason I ask is because there is another customer I know of that is using this tool on a Window/WSL setup and they recently updated Docker Desktop. This caused a very similar error to what you reported here. They reverted Docker Desktop to an older version (4.27.2) and the tool worked again. Perhaps it’s a similar case here.

I also found this thread on the Docker forums: Bind source path does not exist: <- But it does exist - Docker Hub - Docker Community Forums

It seems if you don’t install Docker from the “proper” source on Linux it can have issues like this as well.

Best Regards,

Hi @jeremias.tx

Sorry for the delay…

We are running TorizonCore Builder in a Windows/WSL machine.
Docker Desktop version is 4.29.

We changed Docker Desktop to 4.27.2 version, now it is able to bundle the containers…

It seems if you don’t install Docker from the “proper” source on Linux it can have issues like this as well.

Yeah, it’s true.

Thank you…

Glad to have been of assistance!