Unable to access i.mx 95 "get started guide" and datasheet


Recently we are trying to access the following links to get the user guide and datesheet of i.mx95 verdin evk:

The above links requested additional login info.We have tried to fill in our email address, but failed to login successfully. The error message is shown below:
“AADSTS90044: National Cloud Request Process Switched off”
Do you probably know how to solve this issue? I am looking forward to your early reply. Thank you in advance.

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


It seems you’re encountering an issue accessing specific resources for the i.MX95 Verdin EVK. The error message you’ve encountered, “AADSTS90044: National Cloud Request Process Switched off,” typically relates to authentication or access issues on the platform hosting the documents, rather than an issue with the documents themselves.

To resolve this issue, please ensure that:

  1. You are accessing the links through a supported web browser. Sometimes, browser compatibility issues can lead to unexpected errors. Trying a different browser or ensuring your current browser is up to date might help.
  2. Your network settings allow access to the Toradex documentation site. Some corporate or institutional networks have strict firewall or proxy settings that might block access to certain sites.
  3. Clear your browser cache and cookies. Sometimes, stale data in your browser can cause login issues.

If the problem persists after trying these steps, it might be a temporary issue with the website or the authentication service. In such cases, waiting a bit and trying again later can sometimes resolve the issue.

Please note, while I aim to provide helpful advice, my capabilities are focused on technical support for Toradex hardware and Torizon software. If the issue is related to website access or account authentication, it’s often best resolved by the platform’s support mechanisms.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

Verdin iMX8M Plus Mezzanine | Toradex Developer Center.

Hi @qiuqiul ,

As discussed in our email, your own address is not authorized by NXP according to signed NDA. But you said your 3 colleagues with authorized email addresses encounter exactly the same issue, right?

BTW, do you mind sharing more screenshots here to show each steps you tried? Make sure use one of the authorized email address to log into NXP SharePoint directory.

Best regards,


Hi @yu.liang.tx ,
Thanks a lot for your kind reply. We have tried with the authorized email but still failed to login.

The screenshot of the error message is shown below:

Best Regards

This is an issue related to Microsoft license in China mainland:

National Cloud Request Process Switched off - Microsoft Community

Reaching out to NXP China for a solution.