UART Encoding - Factory Reset

Doing some updates on Angstrom, I crashed my system and lost access to it.
I am trying to debug by the UART using minicom (baudrate 115200, pins 24,26,27 as specified) but when I power it on, I get a lot of random string and invalid characters. It seems the system is booting, but I can’t read what appears on screen. Is there some way to factory reset the system without the need for UART or USB as the viola card has no USB. Remembering that the debugging procedure is correct, it works with a TK1 card.
I also tried imx recovery mode by shorten pads, but didn’t resolved.

Hi @pedroreis and Welcome to the Toradex Community!

What kind of UART Converter are you using?

The difference between Ixora which you probably used for debugging Apalis TK1 is that on Ixora there is a RS232 Transceiver between the UART Converter and the module, where on Viola there is no such Transceiver. For Viola, you need to a Converter with TTL output similar to this.

Best regards,

Hi @jaski.tx,
Thank you for your reply.
I didn’t realize it could be that. I tried other cables, but no one with TTL.
Changing cable resolved my issue.

Best regards,

Perfect that it works. Thanks for your feedback.