UART Communication


I am using Toradex with Iris carrier board v1.1A
Computer on module ; Colibri IMX6DL v1.0A

I have tried connecting UART A or B channels an RF transceiver’s UART as

TxD to RxD
Rxd to TxD

I can send data to RF transceiver and RF transceiver transmits that data over air.

But RF transceiver can’t send data back to my toradex. I’ve watched TxD and RxD channels.

When My RF transceiver isn’t connected to Toradex or when it is connected to another device it’s TxD pin is normally working and sending data.

But when Toradex’s RxD pin connected to TxD pin of my transceiver that TxD pin cannot be grounded by my RF module. It switches between 3.3V and 2.8V so toradex can’t read it as a logic level.

Here i attached a photo. Blue color is TxD of RF modüle which is connected to RxD of Toradex which cannot be grounded while sending data.



Please have a look at the Iris data sheet or schematic.

The Iris carrier board does have TTL to RS232 transceivers on all UARTs.

When you want to connect a TTL level peripheral to those UARTs you have to disable the RS232 transceiver, otherwise both the RS232 transceiver and the RF transceiver will drive the RX pin.


hi max,

I found this information page of 21 on Iris Carrier Board Technical Datasheet.

but ı dont know how can ı do this ? how can ı give logic low to number of 104 SODIMM Pin Number ?

The SODIMM_104 is driven by i.MX6 ball SD4_DATA0, the GPIO on that ball is GPIO2_IO08. This pin is already muxed in the device tree to have GPIO functionality.

So you can use the GPIO sysfs interface to control the GPIO from userspace.

echo 40 > /sys/class/gpio/export            
echo low > /sys/class/gpio/gpio40/direction

hi max,

I could not found which number of gpio for sodimm_104 pin. for example

echo 40 (which number for sodimm_104 ) >  /sys/class/gpio/export  

ı read this page but ı just foundh this ;

for Colibri T20

gpio-190 (102, I X13 ForceOFF#) in  hi
gpio-191 (104, I X14 ForceOFF#) in  hi

for Colibri T30

 gpio-190 (102, I X13 ForceOFF#) in  lo

 gpio-191 (104, I X14 ForceOFF#) in  lo

but ı am using colimbir imx6 dl computer on module.

Even so I try number of 191 but didnt work . I noticed something,

ı want to change direction or value with echo command but didnt change value or direction .
for ex:

echo 0 > /sys/class/gpio/gpio191/value
cat /sys/class/gpio/gpio191/value

result 0

echo 1 > /sys/class/gpio/gpio191/value
cat /sys/class/gpio/gpio191/value

result 0 

Have you tried 40?

Have a look here: GPIO Alphanumeric to GPIO Numeric Assignment