Try to install Apalis-IMX6_LXDE-Image_2.8.7 on a new Apalis

When we started with the Apalis-IMX6 the Images to use where the now called “BSP Legacy Images” based on Angstrom image. To upgrade a running system to the actual images (using the Toradex Easy Installer) we use the procedure according to your website.

The way is to first install the special edition Apalis-IMX6_LXDE-Image_2.8.7 and then from there you can install a Toradex Easy Installer image. All functioned as expected.

But now I made some tries to go the other way. Starting with a Apalis with the installed image basing on the U-Boot version 2020.07-5.6.0:

Then I tried to install (downgrade) to this special image version Apalis-IMX6_LXDE-Image_2.8.7.

The procedure I made was the same as when upgrading:

Startup and stop in U-Boot.

Then following commands:

env default -a

setenv ipaddr

setenv serverip

run setupdate

Then the command

run update

After some minutes I see following output:

From here on the Apalis is “bricked” and needs a Recovery procedure.

What’s wrong here. Is it not possible to install this Image-Version?

The recommended method for installing any image is through the pre-loaded Toradex Easy Installer. If your module is bricked, you can load the Toradex Easy Installer via USB OTG as outlined in the provided instructions. Since all modules shipped by Toradex come with the Toradex Easy Installer, there’s no need to install the special edition Apalis-IMX6_LXDE-Image_2.8.7 and then from there you can install a Toradex Easy Installer image.

Yes it is clear to me what you are writing.
Here in my lab I am able to recover a bricked Apalis, but as I wrote, we have systems with a “BSP Legacy Images” based on Angstrom image out in the field and those systems are embedded and with no possibility to execute the recovery procedure.
The time will come where we will have to update those images and there we should NOT brick any system.

So PLEASE could you try to answer my question.

Please let me know if I misunderstand:
You’ve built a “legacy image,” and in the process of working with this custom image, the Apalis Module became bricked. Unfortunately, I’m unable to pinpoint the issue with your custom image. I suggest building your custom image in a format compatible with the Toradex Easy Installer (this is indeed feasible even for “older” images, like version 2.8.7 based on the Angstrom distribution). This way, you can seamlessly install your image using the Toradex Easy Installer. If you require further assistance, PLEASE provide more detailed information about your situation and phrase your question more clearly.

No the situation is like this.
In the field we have systems running with the “legacy image”. Everything is ok there.
Now as a preparation I am upgrading in my lab such a “legacy image” to the actual version with Toradex Easy Installer. The way goes over the 2.8.7 based version. This way functioned. Still everything is ok.

Now for safety, because I don’t know what the field engineer will do then, I tried to install such a 2.8.7 based version on a actual version which already is able to handle the Toradex Easy Installer. I think that this could happen … even if it is not necessary.
So I tried this as you can see on my screenshots. Unfortunately did that procedure brick the system.

My question is:
What’s wrong with this procedure. Is it not possible to install this Image-Version?

If your 2.8.7 based version is in a TEZI-compatible format, simply use TEZI to install it, and avoid using the deprecated method shown in your screenshots. I’m still unsure about the issue you’re facing. Are you questioning whether your field engineers can load TEZI via USB OTG? If that’s a concern, please consider our OTA solution.

I think that you gave me the answer by writing “avoid using the deprecated method shown in your screenshots”.