Troubles building and flashing Linux custom images to iMX6 ULL

I would build a Linux Console Image for iMX6 ULL module (256MB V1.0A). I set up
an OpenEmbedded framewok as described here.

Looking to the example configuration file (build/conf/local.conf) I didn’t see any
specific reference to a ULL machine, so I proceeded using the generic “imx6”
machine type.

This process produce an image that I serve by network. My tftp root dir
contains this files tree:

|-- boot.vfat
|-- flash_blk.img
|-- flash_eth.img
|-- imx6dl-colibri-aster.dtb
|-- imx6dl-colibri-cam-eval-v3.dtb
|-- imx6dl-colibri-eval-v3.dtb
|-- mbr.bin
|-- root.ext3-100
|-- root.ext3-101
|-- root.ext3-102
|-- root.ext3-103
|-- root.ext3-104
|-- root.ext3-105
|-- root.ext3-106
|-- root.ext3-107
|-- root.ext3-108
|-- root.ext3-109
|-- SPL
|-- u-boot.imx-spl
|-- uImage
`-- versions.txt

I configure u-boot to communicate with my pxe server, and this work fine. Then
I run setup commands but u-boot does not find the espected files:

Colibri iMX6ULL # run setupdate 
MMC: no card present
starting USB...
USB0:   Port not available.
USB1:   USB EHCI 1.00
scanning bus 1 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
** Bad device usb 0 **
Using FEC0 device
TFTP from server; our IP address is
Filename 'colibri-imx6ull/flash_eth.img'.
Load address: 0x82000000
Loading: *
TFTP error: 'File not found' (1)
Not retrying...

I tried to rename folder in my tftp root to be compliant with request, this way u-boot find files but
flash still don’t work.


The machine name to use is colibri-imx6ull.
Id did not make it into the 2.8b1 release by one commit, sorry about that.


Hi Max,
a new build is running right now and sanity check passed, so I think that this solved the problem.

Thank you!