Touchscreen long press inconsistency

I have an issue with the touchscreen in my WinCE 7 application on VF61.
I am using BSP version 1.7.
I have a button with 2 functionalities depending on how long it is pressed.
Whenever i try to long press (3 seconds) the button on my screen (which should generate OnLButtonDown and OnLButtonUp signals) the buttonUp signal doesn’t fire until the same button (or any other part of the screen) is shortly pressed again.
This happens like 99% of the time, while doing short presses doesn’t seem to be as bad as doing long ones.
Is this a driver issue? the same code on WCE6 didn’t have this problem.
We had a similar problem where the “First touch event after booting device was ignored.” ( WC-2429 but then it was solved, maybe it’s something related to this?

Hi @DeasLab ,

I think your issue has more to do with how “strong” you press then how long. The touch driver will discard touch events that are below a certain pressure. This setting can be adjusted. Some panels need a higher value, some a lower. If the pressure is too less and the X/Y values could jump around producing strange results. The best to test this behavior is to draw a selection box on the explorer desktop on the colibri device. You will see the selection box jumping around if the minimum pressure value (MinZValue) is not set appropriately. Other settings could also be wrong like the settling times between samples.
Take a look at:

Hi @germano.tx ,
these registry values were not present in the original image so I didn’t know about them.
I tried setting “MinZValue” to its maximum value (4095 - Minimum pressure needed to validate all measurements. Highest value means lowest pressure.) and “Sensitivity” to 1 (1=most sensitive) but nothing changed.
Also, I tried pressing harder in our current build and still nothing really changes. When doing single light taps on the touchscreen both “down” and “up” signals get recognized so I don’t think it’s a matter of pressing harder. The command gets accepted when pressing normally, just the longer presses don’t work.
What do you mean exactly by “draw a selection box on the explorer desktop”?

I tried every possible value in the accepted ranges for “MinZValue”, “Sensitivity”, “SettlingTime” and it still doesn’t work.
Any other ideas/suggestions?