Torizon/weston and Portainer Container login user ID and password

I have been using Yocto images in the past but now experimenting with Torizon OS and docker images.

I am able to login via COM port interface and SSH. I changed the password as instructed.
I have a monitor plugged into the HDMI port. On boot it asks me to enter user ID and password. I tried the same one as I used for SSH without luck.

Ditto for the Portainer interface I see when I try the :8840 on the browser.
What are the passwords for both the apps?

IMX6 Colibri, Iris board, Torizon OS
Linux colibri-imx6-10801089 5.4.129-5.4.0+git.ce72bea42c97 #1-TorizonCore SMP Thu Sep 23 15:34:16 UTC 2021 armv7l armv7l armv7l GNU/Linux

Greetings @cdevasia,

When you first open container you should see a screen with a login prompt. The username should be admin and the first time you see this screen is when you set the password for admin. There should be fields for “password” and “confirm password”.

It should look similar to what it shown in the pictures of our Quickstart guide: Starting and Managing Containers with Portainer

These logins are separate from the login for the board’s serial debug/SSH.

Best Regards,
Jeremias

It appears I messed up with my previous attempts. I don’t see a field for confirm password.

Is there a way to reset the passwords for both Portainer and Kiosk-mode browser interface?

I stopped the containers, removed the images and pulled new images but it appears the password is buried some place in the flash drive.

Also, what controls the containers to start automatically on boot? How do I enable/disable containers to run on boot?

Our portainer configuration creates a docker volume with the name portainer_data. This would be my best guess of where this password information is stored persistently. You can remove this volume with the docker volume command.

As for container auto-start. We have a systemd service called docker-compose that auto starts the docker-compose.yml in a pre-determined location. This is what auto-starts Portainer and the related containers. You can just enable/disable this via systemctl.

Best Regards,
Jeremias