Torizon VS integration error

Hardware used:
Colibri iMX6DL 512MB V1.1A
Colibri Evaluation board V3.2
Software Used:
Torizon OS with docker runtime.

I have followed the toradex webinar to add torizon extension for Visual Studio 2017 and i have added the extension and docker in my host pc. Once when i try to connect my device in vs2017, i am able to see my device but i could not see the process, images or containers and it shows ssh error. I have attached the screenshot of the error. Kindly guide me to add my device with vs2017.

Thanks in advance

Dear @nishanth1829,

There have been some known network issues with the extension. We are currently working on a new release that should alleviate these issues.

In the meantime are you able to connect your device to Visual Studio via serial instead?

Best Regards,

Dear jeremias,
I have got this error by using serial (COM) port only. I also tried with ethernet but the same error exists. Every time once when VS2017 detects my device, my device reboots itself and i am not able to see the processes, images and containers.
Thanks and regards

Hi @nishanth1829,

That’s odd the picture you posted of the error seems to suggest you’re attempting to connect via ssh. The device rebooting itself is also very odd.

Just to isolate issues here can you try connecting to the device using some kind of serial terminal program like PuTTY or Tera Term.

Also make sure all the cable connections are secured and the module is firmly seated in the edge connector.

Best Regards,

I have the same issue as the original poster. VS2019, Torizon VS Dev Tools 1.0.0, connecting over the serial port. Putty connects with no issue.


So I connected over the network. Same error at first, but a combination of “refresh” and “update” fixed it.

Thanks for your valuable Feedback.


I had the same issues but I found the problem, and its a daft one.

Windows Studio does not forget about SSH connections; it makes duplicates with conflicting parameters, each time you reconnect the devices. Once you have a few duplicates, the SSH error appears and you are stuck.

So the way to fix this easily is to

  1. Type in “SSH” in the Search box, and that gives you an option to add and remove SSH connections. Please select it.

  2. Delete all the offenders. I just normally clear all these away. It seems the extensions make some more if you do a reconnect and rebuild your SDK containers.

  3. Reconnect your device (put the username and password in again) and let the module do a reboot.

  4. Rebuild your build container, and then do whatever you want. I am still coding up so I use the Deploy and Debug to run my code and watch it all go horribly wrong.

Bob’s your uncle, back in business.

It just needs Windows people to add an option to wipe these when you create a new project, and remember not to keep re-registering your Colibri device - just hit refresh.

I was a Linux user, using eclipse this windows thing is less hassle, apart from the odd bizarre thing for example this SSH.

Now to go an sort out why I Studio will not let me compile Unistd to write code for a ARM linux, it shouldn’t make any difference if I am using an compiler for Arm.



Thank you for sharing your experience with this issue. I didn’t realize Windows handles SSH connections like this.

No problem. This is my full time job for the moment. My rule is if I can fix it in 4 hours, I will do it and will document it- otherwise I will defer to the real expertise over in the Torizon HQ.