Torizon-vs-code-v2-apollo-x

Hi,

i am trying to get the ‘Torizon VS Code Extension v2 (ApolloX)’ to run but i am confronted with multiple issues from the start.

Vs Code Output:

[11-07 13:51:02.048] Activating ApolloX Torizon ...
[11-07 13:51:02.048] Resolving host IP address ...
[11-07 13:51:02.266] ERROR :: Docker is not installed. Please install Docker: https://docs.docker.com/engine/install/
[11-07 13:51:02.343] ERROR :: Docker compose is not installed. Please install Docker compose https://docs.docker.com/compose/install/
[11-07 13:51:02.425] ERROR :: PowerShell Core is not installed. Please install: https://docs.microsoft.com/en-us/powershell/scripting/install/installing-powershell-on-linux?view=powershell-7.2
[11-07 13:51:02.503] ERROR :: git is not installed.
[11-07 13:51:02.587] ERROR :: avahi-resolve is not installed.
[11-07 13:51:02.668] ERROR :: nmap is not installed.
[11-07 13:51:02.749] ERROR :: iputils-ping is not installed.
[11-07 13:51:02.833] ERROR :: file is not installed.
[11-07 13:51:03.137] Error trying to install git iputils-ping nmap avahi-utils file
[11-07 13:51:03.339] Error trying to install PowerShell
[11-07 13:51:03.438] ERROR :: PowerShell Core is not installed. Please install: https://docs.microsoft.com/en-us/powershell/scripting/install/installing-powershell-on-linux?view=powershell-7.2
[11-07 13:51:03.438] ERROR :: GIT not installed, is not possible initialize project template subsystem
[11-07 13:51:03.439] Checking connected devices ...
[11-07 13:51:03.439] Scanning Torizon devices ...
[11-07 13:51:03.468] ERROR :: Errors during the initialization of ApolloX Torizon Extension.
[11-07 13:51:03.468] HOUSTON WE HAVE A PROBLEM!
[11-07 13:51:03.468] PLEASE READ THE LOGS!
[11-07 13:51:03.470] No device selected as default
[11-07 13:51:03.470] Please select a registered device as default device
[11-07 13:51:03.956] Debian packages list load OK

Vs Code Errors
image

I am running WSL2 with Ubuntu-22.04 and all Prerequisite Dependencies are installed as per your instructions here GitHub - toradex/torizon-experimental-torizon-ide-v2-docs: VS Code Torizon Integrated Development Environment Documentation

Hi @SimonBaur !

Have you tried to perform the “Reload Window” command of VS Code?

Also, where did you install the dependencies? On Windows side or in WSL side?

Best regards,

Hi @henrique.tx ,

yes i tried “Reload Window”, restart VS Code or Windows Reboot also did not work.

On the WSL side i installed gnupg, Docker Engine, Docker Compose and Visual Studio Code on the Windows side.

Best regards

@SimonBaur

please uninstall the extension and make sure to install it in the “WSL remote” environment.

For example type in a WSL terminal:

code .

This will open the VS Code with a connection to WSL, you can check if it’s correct by the label on the footer bottom left:

image

Now you can install the extension on the WSL environment. Also you will notice that there will now be a button with the label Install in WSL: Ubuntu instead only Install.

Let us know if this works for you,
Best Regards.

Hallo @matheus.castello

your proposed solution does work but i also had to install the VS code WSL extension WSL - Visual Studio Marketplace

So my steps where:

  1. Uninstall the ApolloX extension
  2. Install the WSL extension
  3. Launch vs code from a WSL terminal as you described
  4. Install the ApolloX extension

And then everything worked as it works on linux. Maybe you could enhance your instructions to include this.

Best Regards
Simon

1 Like

Great! Thanks for reporting, we will add this to the documentation.

Best Regards