Torizon project build failure

I have a problem with a Torizon project I’m working on. Generally, my build/debug cycle is going fine, but after a while the build fails because a file path name gets too long. What is happening is that the “/appconfig_0/work” folder gets recursively nested. Here is a screen shot of what is happening:

If I delete the nested part of the folder structure, then everything works fine again (until the nesting gets too long again).

What is causing this and how can I prevent it?

Greetings @bcpberry,

This seems like the issue here: Torizon IDE Extensions Issue Tracker

That should have been fixed already.

What version of our VSCode extension are you working on? Also what kind of project are you working with? In the original issue this only happened on .NET type projects.

Also can you observe what actually causes the recursion? Is it building the project? Debugging? Or some other action?

Best Regards,

Hi Jeremias,

Thanks for the fast response. As per your link, this certainly does seem like the same issue listed as TIE-506, which is marked as fixed for V1.4.

Answers to your questions:

  • I am running V1.4.0 (Updated 3/17/2022, 02:23:11) of the extension.

  • This is a C#/.NET project.

  • The new nested folder is being created every time I start a debug session (F5). If I stop a debug and start it again without making any code changes, another nested folder is created. Just doing a build does not create the folder.

Hope this helps,

I’ve been trying to reproduce this myself but I’ve been unable. I made sure I was on version 1.4 and did the following:

  • Create a fresh .NET console project (I’ve tried .NET 6 and .NET 3.1)
  • Once project was generated I hit F5 to start debugging with no modifications to the default project
  • I cycled through debugging and stopping a few times to make sure

Then I checked my file structure of the project and I don’t see any recursion of folders on my setup.

As a sanity check could you see if this happens with a fresh unmodified .NET project? Also maybe try re-installing the entire extension. Right now it really looks like you somehow are experiencing this old bug that should be fixed.

Best Regards,

I did as you asked and tried a new basic “Hello World” app and, as you experienced, it does not exhibit this problem.

I then had a look at another project I started at the same time as the original one I reported, and it does exhibit this problem. So it seems there is something lingering in the way something was originally created in these older projects (I created them both around the middle of last year using whatever version of the tools was current then).

One thing I noticed is that the existing projects are referencing “dotnet-50_bullseye” whereas the new test one is referencing “dotnet-60_bullseye”. I tried changing the test one back to “50” (by editing torizon-vscode-settings.yaml) but this seemed to make no difference. I do not know what the significance of this setting is (maybe I should ???).

Sorry, forgot to mention in my previous post - I did re-install the extension.

I checked the change that we did in order to fix this issue the first time. It seems we modified the template for .NET projects so that they the following line in the *.csproj file:


If this is really the case then it makes sense why your old project still exhibits this bug since it would have been generated before this fix.

From what I understand this was only needed in some .NET projects and not all of them. Basically it will prevent the project from adding itself inside itself. Could you try manually editing your old project’s *.csproj file to have this line and see if that alleviates the issue?

Best Regards,

Great - that has fixed it!

For reference, this line is not included when the “console” template is used, but is included when the Blazor template is used.

Thanks for pursuing this Jeremias.

All the best,

Glad I could help out.