Torizon getting started VS extension can't connect to server


Trying to get through getting started and am at the point where I am viewing hidden windows and did View->Other Windows->Torizon Devices. The window says “Can’t connect to server. Please check that docker is installed on this PC and start server application”. Is that the same as running Docker Desktop? Docker Desktop is running as per previous lesson and I am able to look at version and run “hello-world” from command line.

I’m not sure if the “Torizon Download/update base and sdk containers” worked. The only message I got on the output console was “Testing if backend service and docker are up and running…”

A check of services.msc shows that Docker Desktop Service is running. HV Host Servce, Hyper-V Host Compute Service and Hyper-V Virtual Machine Management services are running.

I was able to detect the Apalis iMX8QM 4GB WB/IT V1.0B device and it did cause a re-boot. Clicking the refresh icon does nothing.

I have no problem logging in via SSH. What do I do now? Thanks.


From the command line and the same from inside Visual Studio Power Shell it would appear the server is running and shows the 3 times I ran “hello-world”.

C:\Windows\system32>docker info
 Debug Mode: false

 Containers: 3
  Running: 0
  Paused: 0
  Stopped: 3
 Images: 1
 Server Version: 19.03.12
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
 runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
 init version: fec3683
 Security Options:
   Profile: default
 Kernel Version: 4.19.76-linuxkit
 Operating System: Docker Desktop
 OSType: linux
 Architecture: x86_64
 CPUs: 2
 Total Memory: 1.945GiB
 Name: docker-desktop
 Docker Root Dir: /var/lib/docker
 Debug Mode: true
  File Descriptors: 40
  Goroutines: 52
  System Time: 2020-08-15T20:21:40.108032205Z
  EventsListeners: 3
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false
 Product License: Community Engine


So when the extension says “Can’t connect to server” is the server something on the Windows machine, on the target module or something online?

Is there a log showing what the extension is trying to do in detail? Thanks.


I had to uninstall the VS extension and re-install it. A couple of points:

  • Don’t just have started Docker Desktop app. Make sure it successfully started and is running. Likely had to start it as administrator anyway but if you have a choice start as administrator.
  • Start Visual Studio as administrator. That way when you spawn the VisualStudio Marketplace it is likely at administrator level too.
  • After you’ve gotten through the VS extension installation restart VS as administrator.

Your IT guys hate it and it might be painful but you just need to do everything here as administrator!

Greetings @ChipW,

It sounds like you were able to resolve these issues by reinstalling and running most components as administrator? Are you still having issues after this?

It seems strange you needed admin rights though. Let me run this by the team who works on our IDE extensions. I agree that having to run things as admin is not an ideal experience and depending on certain setups may not be possible for some individuals without having to ask IT first.

Best Regards,

I created the Error doing debug and deploy build on VS for getting started - Technical Support - Toradex Community ticket when I got further along. This particular step is done. The only problems you run into in general is some of the default locations for app date go to different places if you do things as administrator than as regular user. Just have to pay attention.

One other thought is that usually when initially using the extension windows firewall/defender complains about moses.exe (our extension backend). Which you need to tell windows to allow. Did you ever see such a message? Perhaps this was the issue and you were able to get around it by running/installing things as administrator.