Torizon Extension in VS 2019 Issues

Hi,
I’ve attempted to follow the instructions (here) to install the Torizon extension for VS2019.

Some notes:

  • All is well until step 3. I have this option: “Torizon:Download/Update sdk and base containers”. Clicking doesn’t do anything.
  • Progress bar in VS2019 that never goes away unless I have the Torizon extension disabled.
  • Docker is running before VS2019 startup
  • Edited the docker daemon file to set buildkit to “false”
  • Computer is connected to Verdin development via ethernet connection
  • SSH is successful through Putty
  • Not seeing moses.exe in processes
  • I’ve uninstalled and reinstalled the extension multiple times without any change in behavior

Running Windows v2004 19041.746 build

Any help is appreciated.

Picture of what I’m seeing.

Greetings @bugrobotics,

Unfortunately it’s not immediately obvious what is wrong with your setup.

One thing you can do is turn on the debug Window for our extension. This can be done by going to Visual Studio and, Tools > Options > Torizon > Show backend console > True. Once that has been set and applied, restart Visual Studio. You may also need to end the moses.exe process via task manager for this change to take effect. But once applied and restarted there should now be a command prompt window that shows all the API calls made by our extension.

Can you try again with the debug window open. Then when you hit this issue copy and paste the contents of the debug window from start up to the error occurring. This should give me a better idea of what exactly is wrong.

Best Regards,
Jeremias

Hi @jeremias.tx ,
Thanks for the reply. Unfortunately, I’ve tried “Show backend console” and it never shows up. I’ve restarted numerous times (VS2019 and the computer). moses.exe isn’t showing up in the processes.

Also, there is no Torizon log file being created where it states there should be one.

So then the issue seems to be the extension backend, moses itself is having issues even starting up. Another thing you can try is executing the moses.exe executable itself via command prompt. The executable should be in the VS folder in the appropriate extension folder.

Try executing this manually and even if it fails see if there’s any additional information produced from a manual execution.

Best Regards,
Jeremias

I ran in cmd and received the following message:
Serving on http://kubernetes.docker.internal:5000

moses.exe was found here:
C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\Extensions\ujdmjqr5.hii\Server

Got it sorted. Wiped everything and did a complete reinstall. During the first VS2019 startup, following the install of the Torizon extension, I ran moses.exe in the command prompt and immediately VS2019 started behaving as expected. Not sure if that was a coincident or not. Everything is working as expected.

UPDATE: I am having to run moses.exe manually to get the extension to properly load. If I don’t run moses in the command prompt then the Torizon extension will not initialize.

Any idea why moses wouldn’t start on it’s own?

Hi @bugrobotics,

After researching this rather strange issue, It turns out there’s an existing bug that explains this:

https://developer.toradex.com/software/torizon/torizoncore-ide-extensions-release?view=all&key=TIE-308

I missed this earlier when you mentioned the issue with the non-existing log file. So it turns out the issue is your windows user “Bug Robotics” which is causing a log path with space character in it. The bug still hasn’t been addressed yet, so for the time being you’ll have to workaround it unfortunately.

Best Regards,
Jeremias

I’m still having issues with the extension. After starting moses.exe I can get successfully connected (where the folders are showing up below the module in “Torizon Devices” window) to the Verdin module every once in a while. The majority of attempts I receive the error shown below:

JSON integer 5000000000 is too large for an Int32. Path’[3].Config.Healthcheck.Interval’, line 757, position

No clue if this is tied to the user name issue but I wouldn’t assume so as the error is intermittent.

So are you now able to get the extension to start normally? Or are you still doing your workaround with starting it manually?

As for your new error, I can’t reproduce this and I’m not familiar with that error message. Can you please enable the debug window as I described earlier? Once enabled can you try connecting to the device again. Then if you could copy and paste the logs that are produced when this connection error occurs. Maybe then we’d have a better idea of what is going on.

Best Regards,
Jeremias

Hi Jeremias,

A few notes:

  • I was not able to get the extension to connect to the Torizon module with any consistency (maybe 20% success rate).
  • I could SSH in, using Putty, without issue.
  • I enabled the debug window shortly after I started having connectivity issues, I’ve never seen the debug window or the log file. Are you referring to the “Output” window? I was receiving errors in Powershell when running moses. That log of errors is attached. link text
  • The board was shutting off during the connection process.

---------------------------------------------The next day------------------------------------------------

  • After writing my comments last night I went into recovery mode and reloaded the Torizon image.
  • Since then I’ve been able to consistently load the extension (still manually starting moses) and connect instantly to the module when VS starts.

As of writing now, the connection is stable. I will keep you updated on anything else that pops up. I really appreciate the quick response to my questions.

Huh this is very odd, I’m not sure what’s going on regarding the device connection. But it seems it’s resolved now? I’d still like to know what caused the issue in the first place if you’re able to figure it out.

As for the issues with needing to manually start moses. I took a quick look at the moses powershell session you shared. What’s immediately as odd was all the INFO:root:REST <- /api/version/docker - 500 messages. The 500 return code indicates something is going wrong and it can’t parse/communicate with the Docker running on your machine. Perhaps something went wrong with your Docker installation? Maybe try reinstalling this.

Best Regards,
Jeremias

The -500 error messages occurred when the device was turning off during an attempt to connect.

After going into recovery mode and loading Torizon again, there hasn’t been any of these errors and the development board is not turning off.

So then the only issue is the extension backend not starting automatically, correct?

As I said before the logs indicate something strange might be going on with your docker installation. Could you try reinstalling and see if this alleviates the remaining issue?

Best Regards,
Jeremias