Torizon error: 'NoneType' object has no attribute 'local_bind_port'

I’m working through the Torizon readme on this page:

I have installed a Torizon image on my iMX7 module. I chose the image called, “TorizonCore image with Docker runtime (PREEMPT_RT) v0.3a1.114 (2019-02-16)”. I have installed the Torizon add-on for Visual Studio.

Visual Studio can see my module, but it can’t read any details from it. I see this error message in the Torizon Devices window. I am connected using Ethernet.


If I ignore that message and try to deploy the hello world application anyway then I get this error:

Loading application configuration...
Checking container state...
Deploying and starting remote container...
Exception while deploying/running container to target.
Code: 500
Description: Internal server error
Message: 'NoneType' object has no attribute 'local_bind_port'
Deploying application...

I think I’m really close to getting started with evaluating Torizon, can you tell me what this message means?

Can you try to restart docker and check that you can connect to your device using ssh (user: torizon and password torizon)?
You may also need to replace the device name with ip address, sometimes the rsync tool running inside container has issues resolving local network names.

There is a change in our latest Torizon images that generates a glitch in the way device is configured by the Visual Studio extension.
I am working on the issue, but next week I’ll be at the Embedded World conference, so I may not be able to release an update.
As a workaround you can log in to your device (you can use ssh over network or a serial terminal configured at 115200bps 8N1) using torizon/torizon as username and password and then run the following commands:

sudo mkdir -p / etc/systemd/system/docker.service.d
sudo sh -c "echo '[Service]
ExecStart=/usr/bin/dockerd -H fd:// -H tcp://
' > /etc/systemd/system/docker.service.d/override.conf"

On first command system will prompt for a password, “torizon” will work.
Second command must be entered on multiple lines, as shown here.
After this you can do:

sudo reboot

and you should be able to access the information on your device.
Sorry for the issue

Thanks @valter.tx, I am able to connect using SSH. I connected to the device and executed the commands that you suggested and that solved the first problem. I can now download the details like the processes running on the connected device in Visual Studio.

When I try to deploy and debug the hello world application I get this message, and then nothing happens:

Loading application configuration...
Checking container state...
Deploying and starting remote container...
Configuring project...
Error loading Torizon application configuration.
Code: 500
Description: Internal server error
Message: [Errno None] Unable to connect to port 32768 on or ::1
Deploying application...

Should I try installing an older image on my device, rather than using the latest one?

I know that I’m testing alpha software here, so no need to say sorry about issues. I’m keen to help you move this project forward as I think this could be a great platform for us to use for future products.

I noticed that I was already using the oldest available image, so I tried updating to the latest image instead. It’s working now, but I’m not sure if the solution was the new image or a reboot of my PC. I think that I may have had some dead Visual Studio processes in the background which showed no visible window, and a reboot cleaned those up.

Perfect that it works. Thanks for the feedback.