Torizon Display calibration not working

Hi

I would like to calibrate my 7’’ capacitive touch display (toradex hw) as described here: Touch Screen Calibration (Torizon).
But the display is black, nothing happens. I see in the log that some cursors could not be loaded.

2446-ddee.png

colibri-imx8x-06748730:~$ docker run -ti --rm --privileged -v /dev:/dev -v /run/udev/:/run/udev/ -v /etc/udev/rules.d:/etc/udev/rules.d -e ACCEPT_FSL_EULA=1 torizon/arm64v8-debian-weston-touch-calibrator
NXP EULA has already been accepted.
Date: 2020-12-08 UTC
[15:01:29.532] weston 5.0.0
               https://wayland.freedesktop.org
               Bug reports to: https://gitlab.freedesktop.org/wayland/weston/issues/
               Build: unknown (not built from git or tarball)
[15:01:29.532] Command line: /usr/bin/weston
[15:01:29.532] OS: Linux, 4.14.170-4.0.0-devel+git.cd185ff20570, #1-TorizonCore SMP PREEMPT Thu Aug 20 12:44:17 UTC 2020, aarch64
[15:01:29.532] warning: XDG_RUNTIME_DIR "/tmp/weston-xdg" is not configured
correctly.  Unix access mode must be 0700 (current mode is 755),
and must be owned by the user (current owner is UID 0).
Refer to your distribution on how to get it, or
http://www.freedesktop.org/wiki/Specifications/basedir-spec
on how to implement it.
[15:01:29.533] Using config file '/etc/xdg/weston/weston.ini'
[15:01:29.534] Output repaint window is 16 ms maximum.
[15:01:29.534] Loading module '/usr/lib/aarch64-linux-gnu/libweston-5/drm-backend.so'
[15:01:29.536] initializing drm backend
[15:01:29.542] using /dev/dri/card1
[15:01:29.542] DRM: supports universal planes
[15:01:29.542] DRM: supports atomic modesetting
[15:01:29.542] DRM: does not support picture aspect ratio
[15:01:29.542] Loading module '/usr/lib/aarch64-linux-gnu/libweston-5/gl-renderer.so'
[15:01:29.556] EGL client extensions: EGL_EXT_client_extensions
               EGL_EXT_platform_base EGL_KHR_platform_wayland
               EGL_EXT_platform_wayland EGL_KHR_platform_gbm
[15:01:29.562] warning: neither EGL_EXT_swap_buffers_with_damage or EGL_KHR_swap_buffers_with_damage is supported. Performance could be affected.
[15:01:29.562] EGL_KHR_surfaceless_context available
[15:01:29.569] EGL version: 1.5
[15:01:29.569] EGL vendor: Vivante Corporation
[15:01:29.569] EGL client APIs: OpenGL_ES
[15:01:29.569] EGL extensions: EGL_KHR_fence_sync EGL_KHR_reusable_sync
               EGL_KHR_wait_sync EGL_KHR_image EGL_KHR_image_base
               EGL_KHR_image_pixmap EGL_KHR_gl_texture_2D_image
               EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image
               EGL_EXT_image_dma_buf_import
               EGL_EXT_image_dma_buf_import_modifiers EGL_KHR_lock_surface
               EGL_KHR_create_context EGL_KHR_surfaceless_context
               EGL_EXT_create_context_robustness EGL_EXT_protected_surface
               EGL_EXT_protected_content EGL_EXT_buffer_age
               EGL_ANDROID_native_fence_sync EGL_WL_bind_wayland_display
               EGL_WL_create_wayland_buffer_from_image EGL_KHR_partial_update
[15:01:29.569] GL version: OpenGL ES 3.1 V6.2.4.p4.190076
[15:01:29.570] GLSL version: OpenGL ES GLSL ES 3.10
[15:01:29.570] GL vendor: Vivante Corporation
[15:01:29.570] GL renderer: Vivante GC7000L
[15:01:29.570] GL extensions: GL_OES_vertex_type_10_10_10_2
               GL_OES_vertex_half_float GL_OES_element_index_uint
               GL_OES_mapbuffer GL_OES_vertex_array_object
               GL_OES_compressed_ETC1_RGB8_texture
               GL_OES_compressed_paletted_texture GL_OES_texture_npot
               GL_OES_rgb8_rgba8 GL_OES_depth_texture
               GL_OES_depth_texture_cube_map GL_OES_depth24 GL_OES_depth32
               GL_OES_packed_depth_stencil GL_OES_fbo_render_mipmap
               GL_OES_get_program_binary GL_OES_fragment_precision_high
               GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_EGL_sync
               GL_OES_texture_stencil8 GL_OES_shader_image_atomic
               GL_OES_texture_storage_multisample_2d_array
               GL_OES_required_internalformat GL_OES_surfaceless_context
               GL_OES_copy_image GL_OES_draw_buffers_indexed
               GL_OES_texture_border_clamp GL_OES_texture_buffer
               GL_OES_texture_cube_map_array GL_OES_draw_elements_base_vertex
               GL_OES_texture_half_float GL_OES_texture_float
               GL_KHR_blend_equation_advanced GL_KHR_debug GL_KHR_robustness
               GL_KHR_robust_buffer_access_behavior
               GL_EXT_texture_type_2_10_10_10_REV
               GL_EXT_texture_filter_anisotropic
               GL_EXT_texture_compression_dxt1 GL_EXT_texture_format_BGRA8888
               GL_EXT_texture_compression_s3tc GL_EXT_read_format_bgra
               GL_EXT_multi_draw_arrays GL_EXT_frag_depth
               GL_EXT_discard_framebuffer GL_EXT_blend_minmax
               GL_EXT_multisampled_render_to_texture
               GL_EXT_color_buffer_half_float GL_EXT_color_buffer_float
               GL_EXT_robustness GL_EXT_texture_sRGB_decode
               GL_EXT_draw_buffers_indexed GL_EXT_texture_border_clamp
               GL_EXT_texture_buffer GL_EXT_copy_image
               GL_EXT_texture_cube_map_array GL_EXT_multi_draw_indirect
               GL_EXT_draw_elements_base_vertex GL_EXT_texture_rg
               GL_EXT_protected_textures GL_EXT_sRGB GL_VIV_direct_texture
[15:01:29.571] GL ES 2 renderer features:
               read-back format: BGRA
               wl_shm sub-image to texture: yes
               EGL Wayland extension: yes
[15:01:29.591] event1  - AD7879 Touchscreen: is tagged by udev as: Touchscreen
[15:01:29.592] event1  - AD7879 Touchscreen: device is a touch device
[15:01:29.661] event3  - Logitech G9x Laser Mouse: is tagged by udev as: Mouse
[15:01:29.661] event3  - Logitech G9x Laser Mouse: device is a pointer
[15:01:29.670] event4  - Logitech G9x Laser Mouse: is tagged by udev as: Keyboard
[15:01:29.670] event4  - Logitech G9x Laser Mouse: device is a keyboard
[15:01:29.673] event2  - gpio-keys: is tagged by udev as: Keyboard
[15:01:29.674] event2  - gpio-keys: device is a keyboard
[15:01:29.677] event0  - sc-powerkey: is tagged by udev as: Keyboard
[15:01:29.677] event0  - sc-powerkey: device is a keyboard
[15:01:29.678] Touchscreen - AD7879 Touchscreen - /sys/devices/platform/5a800000.i2c/i2c-17/17-002c/input/input1/event1
[15:01:29.678] input device event1 has no enabled output associated (none named), skipping calibration for now.
[15:01:29.708] DRM: head 'DPI-1' found, connector 29 is connected, EDID make 'unknown', model 'unknown', serial 'unknown'
[15:01:29.709] Registered plugin API 'weston_drm_output_api_v1' of size 24
[15:01:29.710] Chosen EGL config details:
               RGBA bits: 8 8 8 0
               swap interval range: 1 - 60
[15:01:29.711] No backlight control for output 'DPI-1'
[15:01:29.711] Output DPI-1 (crtc 31) video modes:
               800x480@64.5, preferred, current, 33.3 MHz
[15:01:29.711] associating input device event1 with output DPI-1 (none by udev)
[15:01:29.712] associating input device event3 with output DPI-1 (none by udev)
[15:01:29.712] associating input device event4 with output DPI-1 (none by udev)
[15:01:29.712] associating input device event2 with output DPI-1 (none by udev)
[15:01:29.712] associating input device event0 with output DPI-1 (none by udev)
[15:01:29.712] Output 'DPI-1' enabled with head(s) DPI-1
[15:01:29.712] Compositor capabilities:
               arbitrary surface rotation: yes
               screen capture uses y-flip: yes
               presentation clock: CLOCK_MONOTONIC, id 1
               presentation clock resolution: 0.000000001 s
[15:01:29.713] Loading module '/usr/lib/aarch64-linux-gnu/weston/desktop-shell.so'
[15:01:29.716] launching '/usr/lib/aarch64-linux-gnu/weston-keyboard'
[15:01:29.723] Loading module '/usr/lib/aarch64-linux-gnu/libweston-5/xwayland.so'
[15:01:29.745] Registered plugin API 'weston_xwayland_v1' of size 32
[15:01:29.745] Registered plugin API 'weston_xwayland_surface_v1' of size 16
[15:01:29.746] xserver listening on display :0
[15:01:29.746] launching '/usr/lib/aarch64-linux-gnu/weston-desktop-shell'
could not load cursor 'dnd-move'
could not load cursor 'dnd-move'
could not load cursor 'dnd-copy'
could not load cursor 'dnd-copy'
could not load cursor 'dnd-none'
could not load cursor 'dnd-none'
could not load cursor 'dnd-move'
could not load cursor 'dnd-copy'
could not load cursor 'dnd-none'
[15:01:30.522] input device event1: applying calibration:
                 1.000000 0.000000 0.000000
                 0.000000 1.000000 0.000000

yes all docker containers stopped,
yes, activated with
dtconf activate colibri-imx8x-display-lt161010-overlay.dts -c fsl-imx8qm-colibri-eval.dtb. (something like that)

I understand, we will move to Torizon 5 at a later time.

this was my first problem, we recognized that the touch is inverted 2 weeks ago, then I tried to start the calibration tools. Because this didn’t work I tried Torizon v5 and the problems with the first login began.
I just tried our software on Torizon v5.1 nightly build and it works. I’ll try to calibrate the touch and come back with a feedback.

I confirm, with V5.1 nightly touch calibration works, we will continue with this version. thank you for your support!

@syntom,

Have you disabled all other containers?

docker stop $(docker ps -q)

And have you configured your display according to the setup for TorizonCore 4? See here Setting up Displays with Torizon.

And a little complement:

I know this is a delicate topic, but TorizonCore 4 is now discontinued, and we’ll not provide support for it.

I strongly advise you to move to TorizonCore 5, which will be our Production Release and has continuous support.

Best regards,
André Curvello

You don’t know how happy I am to know that your problem is now solved, and you can work with TorizonCore 5 :slight_smile:

I wish you success with your project!

If you need anything, we are here to help.

Best regards,
André Curvello