Toradex Version 5.x.y tdx-reference-multimedia-image libunistring-0.9.10-r0 do_compile: oe_runmake failed

When building “tdx-reference-multimedia-image”. libunistring gives an error and the build cannot continue. The target when imx6 is specified may not be set.

[upload|Kjz9UjbZTbJpxFe9sD8gE68gVFk=]
[upload|xOAEjsO5LChUy37CFqLB1nueAwY=]

link text

Dear @takehito_yoshida , can you try with the tdx-xwayland (without RT) distro and see if that solves the issue?

Dear @alvaro.tx ,I will try it immediately and report it. {tdx-xwayland (without RT) distro}

Dear @alvaro.tx ,Unfortunately, the result was the same.

Thanks for checking @takehito_yoshida .

Any idea where is the libunistring requirement in those Qt components that you added? This looks like a Qt dependencies issue, so maybe after checking what is the Qt component giving an issue, you can ask at the Qt forum for some details. Unfortunately, we don’t have much more details as we take the Qt public repository and add it almost as-is to our BSPhttps://forum.qt.io/category/11/mobile-and-embedded: https://forum.qt.io/category/11/mobile-and-embedded

I could check that the version of Qt added in BSP 5.2.0 is dunfell:

Sorry to ask you this but after checking what is the Qt component that is using libunistring, could you ask to the Qt forum?

Sorry and kind regards,
Alvaro.

Dear @alvaro.tx ,understood. Let’s check by specifying the Qt options one by one. It will take some time, but I will report the result.

Currently, there is an error in openssh running “DISTRO_FEATURES =” qt5-static “”.

I’ll report again.

Dear @takehito_yoshida , any luck so far regarding this issue?

Dear @alvaro.tx .

I still get an error when I add the “qt5-static” option. But I found a solution.

“Connman connman-client connman-plugin-wifi” is not compatible with “qt5-static”.

I added the following to local.conf and the problem was solved.
IMAGE_INSTALL_remove = “connman connman-client connman-plugin-wifi”

The problem has been resolved. Thank you.

alt text

Interesting, thanks for your feedback. Do you use connman in your project? Does it affect your network configuration? Most of the configuration can be done through systemd-network

No, the project doesn’t use “connman”. Use systemd-network. Thank you.

“Tdx-x wayland” → Success
“Tdx-x wayland-rt” → Success

The problem has been completely resolved.

Perfect, thanks for the confirmation. Good luck with the rest of your development.

Dear @alvaro.tx .

No error has occurred with options other than “qt5-static”. This week I’m going to try the “qt5-static” option for the first time in the 5.3.0 version.

DISTRO = “tdx-xwayland”
DISTRO_VERSION = “5.3.0-devel-20210514075912+build.0”

No error OPTION

ACCEPT_FSL_EULA = "1"    
DISTRO = "tdx-xwayland"    
BB_NUMBER_THREADS ?= "2"    
PARALLEL_MAKE ?= "-j 2"    
LICENSE_FLAGS_WHITELIST = "commercial"    
PACKAGECONFIG_remove_pn-qtbase = " tests examples tools icu accessibility "    
PACKAGECONFIG_append_pn-qtbase = " gles2 linuxfb gl "